GMC Terrain, Equinox, and SRX Forum banner

21 - 40 of 53 Posts

·
Registered
Joined
·
1 Posts
2014 the same?

I may be doing this on Saturday. My air is only blowing out the front vents. The indicator buttons show the change, but nothing does. Do you think re calibrating may work? I recently had my oil changed at a Firestone. They are actually looking at it now, while I have bee googling the issue.
Thanks in advance.
 

·
Registered
Joined
·
5,437 Posts
I may be doing this on Saturday. My air is only blowing out the front vents. The indicator buttons show the change, but nothing does. Do you think re calibrating may work? I recently had my oil changed at a Firestone. They are actually looking at it now, while I have bee googling the issue.
Thanks in advance.
Greeting and Welcome to the Forum.

All the information you would need is in this thread. JUST FYI. . . the mode door actuator is on the left side of the HCAC box and can be reached fairly easily. It is sort about on the left side of the radio chassis and pistures are in this thread. I do not know that I would trust a :Firestone" auto repair with this. They may cause more issues if they arr not familiar with this and go by some Haynes manual or other manual. They do NOT need to disassemble a lot to do this. And, . . .the part is relatively cheap. Many have done this themselves.
 

·
Registered
Joined
·
1 Posts
You're welcome! Glad it worked out for you! :thumb:
I followed your instructions and was able to fix my wife's 2013 Equinox. It was the mode door and I will make 2 comments. That "3rd" screw on top of the actuator looked really daunting and then I decided to see what size socket would fit the screw. Turns out a 6mm socket will do the trick, so I used the ratchet with the 1/4" drive and 6mm socket and got if off handily.
Secondly it took the reset advice above from "sbart" to help me finish up.
I really appreciate your post, thank you much!
 

·
Registered
Joined
·
3 Posts
Thanks for all the info which really helped me. I'm in my sixties and had no skinny teen to help me do the upside down act from the seat. I decided to remove the 2 bolts holding the power seat and removing it. Gave me plenty of room to work and the blood wasn't rushing to my head and saved my back. My 2012 Terrain has 52000 on it and this site helped solve my misdirected air issue. Thanks again to all that give help on this site.
 

·
Registered
Joined
·
22 Posts
I am now having the same problem. I replaced the actuator a few weeks ago and here we are again. I never did do the reset. I couldn’t find the fuses. It worked for a while after I disconnected the battery for 30 mins or so. Must be a capacitor somewhere because the radio still maintained the stations. I will trypulling the fuses when I get home and go from there.

Yoga- more like acrobatics. I was so sore from this! I am not looking forward to doing it again.

Thanks for sharing.
 

·
Registered
Joined
·
5 Posts
Wife's 2011 Equinox makes the thumping noise when you switch between Recirculate and Fresh air mode. If I remove the glove box and crawl up under there, you can see the door try to go past the fully closed position, and then it thumps for a random amount of time before stopping. Sometimes it's 3-4 seconds, other times it's 30 seconds.

This thing looks IMPOSSIBLE to get to without rolling the entire dash forward, unless somebody knows a trick I'm not aware of. I had the top portion of the dash ready to come off (instrument cluster off, radio off, every screw i could find, etc.), but the passenger side just would not budge. Was afraid I'd destroy the airbag if I pulled on it any harder than I was.

What's even more annoying is, if you shut the car off with it still set to Recirculate, about 5 minutes later (key still off) the actuator opens the blend door. So the next time you start the car, it makes the popping noise as it moves back to Recirculate.
 

·
Registered
Joined
·
1 Posts
Thank you so much for this post. Can't believe how much it helped me. Just to add, I was able to remove the 3 bolts that hold the nav/BT base to the body. 10mm bolt in the back, front and the arm. The arm looks like it's held on by a nut. The nut is stationary. A bolt on the inside come off. Removing the base makes it much easier to access the actuator.
As for recalibrating, I turned key on, pressed the auto button and turned key off. Removed negative battery cable for one minute. After one minute I reconnected battery and started vehicle for 4 minutes(do not touch and hvac buttons).
After 4 minutes I shut the vehicle off for 10SECONDS! Restarted and curled controls.
Hope this helps.
THANX AGAIN!!!
MAN I wish I saw this IN THE 1st PLACE!!
Removing that metal nav/BT base OBSTRUCTING EVERYTHING was easy and
made taking off and on the #3 screw possible.
By all means - remove that plate!
 

·
Registered
Joined
·
1 Posts
You're welcome! Glad it worked out for you! :thumb:
This is a well written and photo displayed article....thank you for the extra effort and humor. Can you tell me the part number of the actuator? I am having a tough time finding the actuator that diverts the air between vents and defrost. THanks steveatsunnycaldotcom
 

·
Registered
Joined
·
2 Posts
Thanks for your article, I saved my sister-in-law $500 because of it. It took me an hour and one half to take it out since i didn’t want to mess anything up. It took the same time to put it back in and I also had to twist the actuator like you said just a little bit to get the three screw holes to lineup. I’m a desert guy and didn’t have any skinny kids around. This replacement did scrape up my wrist a little!! Thank you again.
 

·
Registered
Joined
·
1 Posts
I have a 2012 4 cylinder equinox. Heater is stuck on vent mainly, nothing blowing out of defrost. From previous research it said door blend actuator so my neighbor and I changed it out under drivers side. Still no change and I believe we did it right. I am reading some posts on “mode door actuators” is that the issue and if so how do I do it?
 

·
Registered
Joined
·
3,612 Posts
Wife's 2011 Equinox makes the thumping noise when you switch between Recirculate and Fresh air mode. If I remove the glove box and crawl up under there, you can see the door try to go past the fully closed position, and then it thumps for a random amount of time before stopping. Sometimes it's 3-4 seconds, other times it's 30 seconds.

This thing looks IMPOSSIBLE to get to without rolling the entire dash forward, unless somebody knows a trick I'm not aware of. I had the top portion of the dash ready to come off (instrument cluster off, radio off, every screw i could find, etc.), but the passenger side just would not budge. Was afraid I'd destroy the airbag if I pulled on it any harder than I was.

What's even more annoying is, if you shut the car off with it still set to Recirculate, about 5 minutes later (key still off) the actuator opens the blend door. So the next time you start the car, it makes the popping noise as it moves back to Recirculate.
Sounds like we have the same problem. My 2011 V6 Nox has been making the loud thumping noise for several months now. Sounds like a Munchkin inside the dash pounding his fist to get out. Waiting for it to fail completely. I *think* my air is still being directed to the proper areas: it goes to the windshield, out the dash, and below the dash correctly, and I *think* the air blending still works, so I’m not sure what’s gonna fail (the directional, or the blending). On my ‘97 Taurus, the cigarette pack-sized blend door motor failed at least twice due to cracked plastic gears that would cause the blend door to continuously fall down into the COLD position. For a while I was just manipulating it manually by season, fixing the position either all the way up, or letting it fall down. This thumping noise reminds me of that same blend door failure. The directional on the Taurus is controlled by a vacuum system, I believe
 

·
Registered
Joined
·
103 Posts
Wife's 2011 Equinox makes the thumping noise when you switch between Recirculate and Fresh air mode. If I remove the glove box and crawl up under there, you can see the door try to go past the fully closed position, and then it thumps for a random amount of time before stopping. Sometimes it's 3-4 seconds, other times it's 30 seconds.

This thing looks IMPOSSIBLE to get to without rolling the entire dash forward, unless somebody knows a trick I'm not aware of. I had the top portion of the dash ready to come off (instrument cluster off, radio off, every screw i could find, etc.), but the passenger side just would not budge. Was afraid I'd destroy the airbag if I pulled on it any harder than I was.

What's even more annoying is, if you shut the car off with it still set to Recirculate, about 5 minutes later (key still off) the actuator opens the blend door. So the next time you start the car, it makes the popping noise as it moves back to Recirculate.
Sounds like we have the same problem. My 2011 V6 Nox has been making the loud thumping noise for several months now. Sounds like a Munchkin inside the dash pounding his fist to get out. Waiting for it to fail completely. I *think* my air is still being directed to the proper areas: it goes to the windshield, out the dash, and below the dash correctly, and I *think* the air blending still works, so I’m not sure what’s gonna fail (the directional, or the blending). On my ‘97 Taurus, the cigarette pack-sized blend door motor failed at least twice due to cracked plastic gears that would cause the blend door to continuously fall down into the COLD position. For a while I was just manipulating it manually by season, fixing the position either all the way up, or letting it fall down. This thumping noise reminds me of that same blend door failure. The directional on the Taurus is controlled by a vacuum system, I believe



I have the same issue? Everything works but I can see the door closing and then thumping. Any idea what the fix is?
 

·
Registered
Joined
·
3,612 Posts
I have the same issue? Everything works but I can see the door closing and then thumping. Any idea what the fix is?
I think in *my* case it's the "Mode Control Cam" (left side dash), which has a couple of "arms" with gear teeth on them. I think either those gear teeth have stripped on one or both "arms" OR the socket they fit into (female) is stripped. If it's the latter, that's probably worse because the former can be removed fairly easily (I think).

What’s strange is - the thumping sound sounds like it’s coming from the right (passenger) side. There *is* another actuator on that side...
 

·
Registered
Joined
·
1 Posts
Sos

I am having the exact problem in my 2012 Equinox (air will change from hot to cold, but will only come out of defrost vents) Took it to the shop and they confirmed the actuator was failing and replaced it, but it did not fix the problem. They are claiming they need to remove the full dash to replace a different actuator. Could this be correct??? My concern was they not calibrate it correctly, but they claim they reset it 5 times and it still won't work.
 

·
Registered
Joined
·
10,223 Posts
I am having the exact problem in my 2012 Equinox (air will change from hot to cold, but will only come out of defrost vents) Took it to the shop and they confirmed the actuator was failing and replaced it, but it did not fix the problem. They are claiming they need to remove the full dash to replace a different actuator. Could this be correct??? My concern was they not calibrate it correctly, but they claim they reset it 5 times and it still won't work.

I would look for another shop. This one does not sound knowledgeable of this repair.
 

·
Registered
Joined
·
2 Posts
Thank you!!!

Please let me add my thanks to you for posting this how to... I purchased a 2015 AWD LTZ Equinox last year to replace a 2004 CRV. I am very pleased with the car. However this spring we noticed that the defrost was not working and air only came from the dash vents. After researching the issue I decided to take a chance and replace the mode door actuator. And your correct - a large sense of humor helps! I didn't have a teenager to help so did the job myself. At 63 I'm not as flexible as I once was but I got the job done. Everything works. I do appreciate the effort to make your post. Thanks much.
 

·
Registered
Joined
·
2 Posts
Just curious if you had an issue with the ac when it rains before you changed this out?
Mine works fine until it rains then it’s no ac for days just hot air
 

·
Registered
Joined
·
1 Posts
Thanks and Heads Up for Replacement Part

Thank you for the post and the courage to tackle this on my own. Like an idiot, I ordered the part based on a quick internet search so I would have it when I started the repair. Buyer beware! There are a lot of websites out there that will try and sell you a 5 pin replacement blend door actuator when you search for mode actuator. On my wife's 2013 Chevy Equinox, once I got it out, it is a 6 pin and the wiring harness was shaped differently than the part it plugs into on the actuator. This was my fault though, so I wanted to give others a heads up. I found a six pin on NAPA, part # TEE ADA245.
 

·
Registered
Joined
·
1 Posts
Followed this awesome guide a few weekends ago.
100 degree heat, 4 hours, and I could be a professional gymnast with my new found flexibility.

My car is a 2012 Equinox.

If you can have the tools to remove the silver plate in front of the actuator, I'd definitely recommend it.
Most of my time was spent trying to get to my hand behind it to take off the actuator.
And like the post above says, make sure you order the correct actuator. I think they differ based on year, and model (equinox, terrain, etc.).
 

·
Registered
Joined
·
19 Posts
My 2011 Equinox "recirc" button is causing a ticking noise.. but can't find a way to remove that actuator, it is more towards the firewall between the engine/ dash. Any ideas how to replace this recirc/ vent actuator?

I already have the part.
 
21 - 40 of 53 Posts
Top