GMC Terrain, Equinox, and SRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey everyone,

Just wondering if I could pick some brains. I keep getting P0300 and P0303 popping up on the OBD. I've exchanged the ignition coil on cyl 3, switched out the spark plugs, replaced the valve ring, had the O2 sensors replaced, ran RP fuel system cleaner, and flushed all of the fluids in the car (even trans, coolant, transfer and diff). Had both dealer and local mechanic take a look and they haven't mentioned anything other than the above.

I've only been using premium gas since the fix, and yet, I'm still getting the CEL when I bring it above 4k RPM for anything more than a couple seconds.

Does anyone have any ideas? Thanks!

2013 SLE 2.4 AWD DOHC
 

·
Registered
Joined
·
571 Posts
Check your fuel pressure, use the live data on a scanner. Also do a compression test on all of the cylinders. A misfire in the higher rpm like that would indicate fuel starvation I would say even a couple bottles of injector cleaner for a full tank. I would also replace all the coils at once and all the plugs for even wear.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Fuel pressure looks to be normal, tbh. Plugs were all replaced, I did only do the 3rd cyl IC but that's because I was only getting P0303 to start with. Now it's just P0300.

What could cause consistent burnout of the spark plug yet not appear at the lower revs?
 

·
Registered
Joined
·
48 Posts
Fuel pressure looks to be normal, tbh. Plugs were all replaced, I did only do the 3rd cyl IC but that's because I was only getting P0303 to start with. Now it's just P0300.

What could cause consistent burnout of the spark plug yet not appear at the lower revs?
You've got to give a lot more background...it's like going to a doctor and saying: "it hurts when I do this"; well how old are you? ...when did it start?, ...what were you doing in the days prior to noticing this pain?, etc. So what's the mileage? What regular scheduled service have done recently? Have you have any major repairs to the engine or fuel systems? Have you noticed degraded fuel economy? Since you have a scanner, what do your fuel trims look like at idle, during cruise and acceleration? How about your EVAP system, what percentage is it functioning at at idle and cruise? How may inches of water is your EVAP system hitting? What's the MAP when the misfires happen? When is the misfire happening, under heavy load, light load, or just revving in park, 2 out of 3, all 3?

It is unlikely a vacuum leak at 4000 rpm is causing a misfire, that also wouldn't stall the engine at idle.
 
1 - 6 of 6 Posts
Top