GMC Terrain, Equinox, and SRX Forum banner
1 - 20 of 44 Posts

·
Registered
Joined
·
2,828 Posts
Discussion Starter · #1 ·
Well, at only 1700kms, POLRCUB is getting a new steering wheel, the inner seem of where the leather and stitching come together is aided by glue, and the glue has let go or there was not sufficient glue applied.

Was quite surprised as the Service Manager was very nice about it. Thought for sure they would simply ask to bring it in and try and glue it themselves!! Ha
 

·
Registered
Joined
·
482 Posts
Ours is right around its first anniversery , last time it saw the dealership was through the back window when we drove it off the lot. (hope saying this isn't a jinx )
 

·
Registered
Joined
·
2,828 Posts
Discussion Starter · #3 ·
Not to worry - knock on wood! :)
 

·
Premium Member
Joined
·
1,054 Posts
Mine was the overhead console map lights. They were sticking in, so when u pushed to turn on it cones on, but when u tried to click off the switch got stuck and u could not grab it to pull it out. They tried to fix it, but no go and just orderd me a brand new console which was nice. Knock on wood hopefully my 12' doesn't have any issues that alot of people on this forum face with their 10's and 11's
 

·
Registered
Joined
·
137 Posts
My first repalacement item was the rear window wiper arm. I grabbed it to pull it outward to clean the window and heard the "snap". Yep, broke it. My dealer replaced it with no trouble.
 

·
Registered
Joined
·
300 Posts
So far the only thing I've had replaced was the storage bin in the center of the dash.
 

·
Registered
Joined
·
72 Posts
EGR valve at almost 5000 miles.


2012 GMC Terrain SLT2 Carbon Black/Gray interior
 

·
Registered
Joined
·
2,828 Posts
Discussion Starter · #8 ·
ADubH said:
EGR valve at almost 5000 miles.


2012 GMC Terrain SLT2 Carbon Black/Gray interior
Hmm, good to know, would seem that the DI would foul those up.[/color]
 

·
Registered
Joined
·
673 Posts
bowtieman said:
Mine was the overhead console map lights. They were sticking in, so when u pushed to turn on it cones on, but when u tried to click off the switch got stuck and u could not grab it to pull it out. They tried to fix it, but no go and just orderd me a brand new console which was nice. Knock on wood hopefully my 12' doesn't have any issues that alot of people on this forum face with their 10's and 11's

I have the same issue, hoping over time it gets loose.
 

·
Registered
Joined
·
13 Posts
Mine was the fuel pump, the fuel pump sensor (?) and something else. All I know it cost $$$$$$$$$$$ and they rented me a SUV for 2 weeks :)

Back in Monday for no front defrost :(
 

·
Registered
Joined
·
24 Posts
I've had mine in for warranty work once and had two things addressed at the same time. The first was the center dash storage compartment do to a broken spring or something in the lid. It would not flip up by itself anymore after only using it 5-6 times. They switched out the entire unit. The other thing we had it in for was do to a linkage issue in the passenger door. The door would open from the outside but not the inside.
 

·
Registered
Joined
·
977 Posts
I have a 2010 4. Been pretty much trouble free. The dealer buffed the paint off the spoiler to the primer(It was a freebie from the salesman) that they had to repaint. The other was a squeak that they could not fix. It was the brake cable covers rubbing together. I just wrapped one with heather hose. I have only 12000 miles and it will be 2 years old June 8. I did get a nail in the tire today . The TPMS indicated it this AM. Put on the spare and got it patched ay my mechanic.
 

·
Registered
Joined
·
6 Posts
I have a 2010 SLT2 V6. Had to have the R/F Bearing and Hub assembly replaced at 16,000 mi due to an internal failure.
 

·
Registered
Joined
·
1,153 Posts
The one and only thing on my 2010 Nox was a popped bolt on the drivers seat lumbar support...in and out of the dealership in about 30 minutes.
 

·
Registered
Joined
·
31 Posts
Like several others, I had to have the lid on the dash storage console replaced. Except that they screwed up and replaced the center armrest console lid instead, so had to order the correct part.
 

·
Registered
Joined
·
86 Posts
pwrmngr said:
Mine was the fuel pump, the fuel pump sensor (?) and something else. All I know it cost $$$$$$$$$$$ and they rented me a SUV for 2 weeks :)

Back in Monday for no front defrost :(
Same here, but I had mine back the next day!
 

·
Registered
Joined
·
18 Posts
Apparently the O2 sensors leading to fuel getting into the oil and causing the engine to suddenly turn off (Both while warming up and while driving)
This happened around 1500(hwy) miles, 4 months.

Then they wanted me to drive it 300 miles to the dealership because that's the closest one (I refused and told them to come and tow it at THEIR expense)
Never gave me a set answer and kinda just huffed it and said it was fixed now
 

·
Registered
Joined
·
533 Posts
On my poor ol' 2012 Equinox; first warranty complaint/service was for misfiring with low rpm high load. (Not fixed btw!) and the first replacement was one of the cats. Had a low efficiency code.

For my '11 terrain; first and only replacement was the key fob. The other problem I had was the nav resetting to Washington, D.C. And time resetting every time I start the car but the dealer found a TSB and had me fixed up in less than 30 minutes. I will say this: my dealer has been fantastic with both cars.


Sent from my bragging iPhone using an app that encourages it.
 

·
Registered
Joined
·
215 Posts
It will be 2 years in April and nothing yet . The car is perfect . The V6 is great we are so glad we got this engine and not the 4cyl
 
1 - 20 of 44 Posts
Top