GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I am getting fed up with GM. Maybe it is just this dealer/service location, but apparently I didn't buy a new 2010 Terrain. It is a 'rig this here' and 'looks normal to me' situation.
Purchased back in march 2010. Had no problems, until the weather cooled down. At this point I wasn't blasting the AC, so I noticed a clack coming from the engine. I have posted earlier on the forum, and got some info about it. So I took it in to have it looked at, to be ignored and said, 'heard nothing'. Pulling out of the dealer, I heard it again. Went back the next day, and had to raise my voice, just to get someone to listen. Finally the mechanic took a ride, heard the noise right away. Said ' may be spark knock'. Took it in, and reprogrammed the ECM/TCM, and told me to switch from Shell gas to another brand and wait for 4 or 5 tanks to clear up. Did that. Still clacking.... took it back in at oil change time, and mentioned it again. They said hmm, we'll look at it. Got it back with 'No abnormal noise heard at this time.' Drove out of the dealer, heard it again. This point my blood is boiling, and the story doesn't end there. I thought, I'll go back to Shell gas(top tier) and give it a few tanks. Just took it back to the dealer for an oil change, and to fix the drooping headliner problem. They threw in a magnet to hold it up instead of replacing the headliner new, which is great for the front dome, but the back dome is still drooping. I brought it to the attention of the service tech, to get 'looks normal'. And to top it off, I go the 'no abnormal noise heard at this time' along with some service bulletins for Top tier gas, and the normal tick of the DI engine. OMFG. I went over all of this stuff with the head mechanic before about what kind of gas, normal noises, all of that. Why the run around? They never pulled anything apart to check for a bad sensor, nothing, just sent me on my merry way. I guess I am just bringing it in for fun. Sorry for the rant, but am I going insane?
 

·
Registered
Joined
·
10,406 Posts
Christina - Can you provide any assistance for this VERY UNHAPPY customer ? He deserves some.
 

·
Registered
Joined
·
109 Posts
I'm sorry to hear about your problems. I had something like this happen to my dad on a GMC Safari van. He heard a click for awhile and they kept on saying nothing was wrong with it. To make a long story short...lemon law


9 months with a car for $900. They reimbursed him the rest. Easy as pie...lemon pie
 

·
Registered
Joined
·
5,052 Posts
as for the headliner--

2010-2011
Condition--Equinox, Terrain - Interior headliner sagging at dome lamp area
DO THIS---Inspect all of the magnet assemblies and repair any magnets that appear loose. Reglue the headliner magnets
DONT DO THIS---- Don't replace the headliner
Ref # PI0253B
 

·
Registered
Joined
·
1,082 Posts
Drive another Terrain on the lot to see if you hear the noise on it. If it doesnt do it, show the dealer and tell them to fix it.

Also, after three tries, why havent you called GM or tried a different dealer that will actually work with you?
 

·
Registered
Joined
·
5,052 Posts
any of these sound like yours?

2010
Equinox, Terrain -- Rattle noise from front of engine at idle
do this- Replace the balance shaft chain and tensioner
dont do this- Don't replace the A/C compressor or the timing chain tensioner.
ref # PI0202

2010-2011
Equinox; Terrain -- Front suspension or front strut noise
do this--Apply grease around the circumference of the strut shaft that is exposed
dont do this-Don't replace any front suspension components
ref # 10-03-08-003
 

·
Registered
Joined
·
27 Posts
Discussion Starter #7
USFwrestler said:
Easy as pie...lemon pie
Lol! I like it!

rbarrios, are you a service tech? Yea, I was told the headliner is a molded piece. Since there is no weight pulling it down, the sagging would be caused by??? I'm no expert, far from it, but common sense tells me if the mold is bad, magnets are temporary fix, and if you dont put magnets all up and down, it is still going to sag, like mine in the rear now.
rbarrios said:
any of these sound like yours?

2010
Equinox, Terrain -- Rattle noise from front of engine at idle
do this- Replace the balance shaft chain and tensioner
dont do this- Don't replace the A/C compressor or the timing chain tensioner.
ref # PI0202

2010-2011
Equinox; Terrain -- Front suspension or front strut noise
do this--Apply grease around the circumference of the strut shaft that is exposed
dont do this-Don't replace any front suspension components
ref # 10-03-08-003
The other two posts don't sound like mine. It is not at idle, only when driving at a constant speed on a flat surface, or moderate acceleration. It is a random noise, not constant. Timing chain tensioner, or something to do with timing - maybe...

bballr4567 said:
Drive another Terrain on the lot to see if you hear the noise on it. If it doesnt do it, show the dealer and tell them to fix it.

Also, after three tries, why havent you called GM or tried a different dealer that will actually work with you?
Thanks for this suggestion, as I was about to do that, but my sales guy was not working yesterday, and I was not able to get out there today. Hopefully I will get some time tomorrow. I havent tried another dealer, because I thought since I bought it there, they should be more than willing to help. Any body else have luck switching dealerships? Just been dealing with this for so long now, its frustrating. Thanks for all the help so far!
 

·
Registered
Joined
·
141 Posts
i had to switch dealers because the one i bought it at was 2.5 hours away and that's a helluva drive for an oil change and some magnets in my roofline lol

we only have one GMC dealer in town so my options were limited on where to take my Terrain, seems like a great outfit though.
 

·
Registered
Joined
·
25 Posts
any of these sound like yours?

2010
Equinox, Terrain -- Rattle noise from front of engine at idle
do this- Replace the balance shaft chain and tensioner
dont do this- Don't replace the A/C compressor or the timing chain tensioner.
ref # PI0202



That's funny. My nox rattled at idle and the dealer couldn't figure it out so they replaced the motor. Idiots.
 

·
Registered
Joined
·
748 Posts
I too have a slight rattle. Ive noticed it only occurs between 30 and 40 mph. Under light acceleration. I have only noticed it after they did my first oil change. It sounds almost like a child rattle. Very faint though and it doesnt do it at idle or if I put the car in neutral and match the rpm revs.
 

·
Registered
Joined
·
85 Posts
rbarrios said:
as for the headliner--

2010-2011
Condition--Equinox, Terrain - Interior headliner sagging at dome lamp area
DO THIS---Inspect all of the magnet assemblies and repair any magnets that appear loose. Reglue the headliner magnets
DONT DO THIS---- Don't replace the headliner
Ref # PI0253B
Problem with that is...

On the NON_SUNROOF models the 2 magnets are near the rear and wont support the middle. They put a 2011 model in mine and it has 4 magnets and is perfect!

The rattle is the injectors as it is similar to that of a diesel being very high pressure and direct injection...
 

·
Registered
Joined
·
27 Posts
Discussion Starter #12
Phantm006 said:
I too have a slight rattle. Ive noticed it only occurs between 30 and 40 mph. Under light acceleration. I have only noticed it after they did my first oil change. It sounds almost like a child rattle. Very faint though and it doesnt do it at idle or if I put the car in neutral and match the rpm revs.
Mine started faint too, gotten louder. Does sound like a rattle, or kind of like you're hitting the gas in a stick shift @ 10 mph in 5th gear. Definitely not a normal sound to me. Did you take it in to look at it yet?
 

·
Registered
Joined
·
748 Posts
riggy said:
Mine started faint too, gotten louder. Does sound like a rattle, or kind of like you're hitting the gas in a stick shift @ 10 mph in 5th gear. Definitely not a normal sound to me. Did you take it in to look at it yet?
Sounds like a small rattle. Like something is loose but its not very big. I haven't taken it in yet because the dealer I take it too seems to only drive it 20 ft for all my complaints. Then I get the "could not replicate" stamp. Master GMC in Augusta GA. BTW. But I know its not something ive done. I rarely even open my hood. Except to check my fluids. It took them three visits for the parking brake thing. And that's only because I told them I know people with the same problem, described the noise, gave them a location for it and told them my next call would be to GM. Ironically they found and fixed it.
 

·
Registered
Joined
·
748 Posts
^^^Well good luck Riggy. If you find out what it is then let me know. I dont know if mine is spark knock or timing. But all of my services have been done at the dealer. Guess I'm left to fend for myself.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #16
Phantm006 said:
^^^Well good luck Riggy. If you find out what it is then let me know. I dont know if mine is spark knock or timing. But all of my services have been done at the dealer. Guess I'm left to fend for myself.
Wow, just happened to check tonight, and got Tricia's message. Never got an alert email from the system. ???
I did take it to another dealer(same dealer, different location) and they were nice after hearing my bad luck at their other location.
They flashed the ECM/TCM again. I would say it helped, as the noise isnt as loud, but it is still there, and now it runs rough. The rpms at idle jump up and down, and the thing vibrates at lights. Maybe worse. The headliner since has fallen back down. I am not sure what glue they used, but it has melted, probably leaving a nice mess on top of the headliner to seep through sooner or later.
I hope Tricia has some magic up her sleeve. I will let you know.
 

·
Registered
Joined
·
748 Posts
@ Riggy try this. Got parts on order for the rattle. Will let you know.
rbarrios said:
any of these sound like yours?

2010
Equinox, Terrain -- Rattle noise from front of engine at idle
do this- Replace the balance shaft chain and tensioner
dont do this- Don't replace the A/C compressor or the timing chain tensioner.
ref # PI0202

2010-2011
Equinox; Terrain -- Front suspension or front strut noise
do this--Apply grease around the circumference of the strut shaft that is exposed
dont do this-Don't replace any front suspension components
ref # 10-03-08-003
 

·
Registered
Joined
·
27 Posts
Discussion Starter #18
Any luck Phantom006? Did they flash your ECM/TCM with the 'December update'?
I don't hear a rattle at idle, it just runs rough, & rpms jump.

I was called by GM. Christina (not sure if it was the same person that works these boards), escalated my case to the district person. The district person pretty much told me to shove it, and good luck, because we (GM) are not going to do anything except the same. Take it to the dealer, where they can attempt to fix it as many times as they want. He knew there had been 4 attempts already, but it didnt matter to GM. He had no answer to any questions, except 'take it back to the dealer, again'. Not the picture of Customer Service that I have heard from others. Pretty much back to square one. I am sending my Lemon defect paperwork today. I am sorry to Tricia(Chevrolet Customer SVC), but you getting the Customer Assistance Office involved has been a step backwards and really has me baffled on how GM keeps anyone happy.
 

·
Registered
Joined
·
748 Posts
Unfortunately Riggy, not yet. My dealer has ordered parts and I called and spoke to the service guy the other day. He said were waiting on bolts. I also told him about my suspension creaking and my lumbar support being broken. I try to keep a cool head because I didn't buy the car from that dealer. But as soon as something changes I'll let you know. Btw, timed to get pissed in your case. I'd call every GM number I could find. Let me know how it goes.
 

·
Registered
Joined
·
748 Posts
Riggy, I got a call tonight from the dealer. Parts are in. Taking to the dealer in the morning. Will advise.
 
1 - 20 of 34 Posts
Top