GMC Terrain, Equinox, and SRX Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I have a 4 cyl..AWD 2011 terrain, first off milage sucks... 2nd problem is the car feels like its running too rich,, sometimes when letting off the gas pedal then giving it gas again it feels like its going to stall out, it just bogs down... also if going around a corner and you give it gas.. it does the same thing.... I never had a 4 cylinder before, but I have rented japanese cars with a 4 cylinder and they had some pep, never the issues I have with my terrain.. does anyone else have this issue?
 

·
Registered
Joined
·
1,153 Posts
It's not really the engine bogging so much as it is the tranny programming. You might want to visit your dealer and see if there is a software flash available to minimize the effect. Alternately, the transmission programming will "learn" your driving style after a while and slightly change shift points accordingly...but I don't know how well that will work in a situation like you described. I noticed the same behavior on mine when it was new...but it has either gone away somewhat, or I have gotten used to it.

btw..these Japanese cars you drove that had "pep" were probably nowhere near the size and weight of your Terrain.
 

·
Registered
Joined
·
44 Posts
bumn said:
I have a 4 cyl..AWD 2011 terrain, first off milage sucks... 2nd problem is the car feels like its running too rich,, sometimes when letting off the gas pedal then giving it gas again it feels like its going to stall out, it just bogs down... also if going around a corner and you give it gas.. it does the same thing.... I never had a 4 cylinder before, but I have rented japanese cars with a 4 cylinder and they had some pep, never the issues I have with my terrain.. does anyone else have this issue?
did you not test drive it before you got it?
 

·
Registered
Joined
·
66 Posts
The "bogging down" is part of programming and is partially the result of a direct-injected engine. The car will always try to get to 5th/6th gear when you are driving and quickly downshift when you let off the pedal in order to give you the best fuel economy. I would agree with NoobNox that the car will start to learn your driving style eventually and feel somewhat less awkward. Give yourself about 1500-2000 miles before you complain about fuel economy because it seems that most owners see improving fuel economy as the engine gets "broken in"
 

·
Registered
Joined
·
29 Posts
vince730 said:
The "bogging down" is part of programming and is partially the result of a direct-injected engine. The car will always try to get to 5th/6th gear when you are driving and quickly downshift when you let off the pedal in order to give you the best fuel economy. I would agree with NoobNox that the car will start to learn your driving style eventually and feel somewhat less awkward. Give yourself about 1500-2000 miles before you complain about fuel economy because it seems that most owners see improving fuel economy as the engine gets "broken in"
I now have about 4500 miles on my 4 cyl. Terrain. I would think it's a "broken-in" as it's going to get, and the mileage still sucks. Mostly city driving since I bought it with probably 1000 miles of the the total in open highway driving. Overall average is 19.7 mpg. Horrible.
 

·
Registered
Joined
·
10,548 Posts
4sight said:
Overall average is 19.7 mpg. Horrible.
Try resetting (zeroing out) the overall average at each gas fill-up to see if the mileage is getting better. You are looking at data from too long a period if you haven't reset the Average Fuel Mileage.
 

·
Registered
Joined
·
949 Posts
4sight said:
I now have about 4500 miles on my 4 cyl. Terrain. I would think it's a "broken-in" as it's going to get, and the mileage still sucks. Mostly city driving since I bought it with probably 1000 miles of the the total in open highway driving. Overall average is 19.7 mpg. Horrible.
Have you had an oil change yet? If not, then I would, even though it's not really required at this point. I experienced even more improvement in MPG after my first oil change.
 

·
Registered
Joined
·
136 Posts
bumn said:
I have a 4 cyl..AWD 2011 terrain, first off milage sucks... 2nd problem is the car feels like its running too rich,, sometimes when letting off the gas pedal then giving it gas again it feels like its going to stall out, it just bogs down... also if going around a corner and you give it gas.. it does the same thing.... I never had a 4 cylinder before, but I have rented japanese cars with a 4 cylinder and they had some pep, never the issues I have with my terrain.. does anyone else have this issue?
See my post http://www.terrainforum.net/index.php?topic=3101.0
http://www.terrainforum.net/index.php?topic=3101.0

ECM programming
1-12637495 New software with improved misfire converter protection
2-12637535 New calibration to improve cold starting
3-12637532 New calibration to improve cold starting
4-12637537 New calibration to improve cold starting
5-12639845 New calibration to address detonation, spark knock and or rattle noise on light acceleration 1500-1900 RPM
6-12650772 New calibration to revert phaser oil control valve frequency back to 150hz for durability concerns
7-12633518 New software
8-12634344 New calibration for start of production

TCM programming
1-24252872 operation system
2-24256214 New calibration to improve the delayed reverse engagement
3-24256216 New calibration to improve the delayed reverse engagement
4-24255173 New calibration to improve the delayed reverse engagement


Same issues we had.Till the update.
Fuel economy still is not the best but as we have a 2.4l AWD with a CAI installed and at times drive it heavy footed :thumb:
 

·
Registered
Joined
·
8 Posts
Received my recall (11195) September 1st. Went on line to google issue and found this thread. I remember having the startup noise about 3 times since the 5 months of ownership that other people were having. I decided that I will call and set up an appointment with service for Monday morning. Sunday night the wife says oh you have an appointment set up for tomorrow at 9:00am. for service on the equinox. I said no! She says yes, they sent you an email reminder for on 9/6/11 @ 9:00am. I said I never made an appointment but I was going to call them. Sure enough appointment was scheduled with out me even picking up the phone. Well that's to weird!!!!!! Monday morning comes around and I call and give my name and tell them I have an appointment set up for 9:00am and ask whats up. The service tech says what do you mean. I said I never made an appointment but I was going to call. They had no clue who made the appointment. I said that's funny I will keep the appointment it's my off day. I said do you have the parts needed for the job. He said hang on I will check and call you back. He calls me back and says yep, the parts dept has your parts with your name on them. OK this is really getting weird. I said ok see you at 9:00. Went in and it took about 1.5 hours while I waited. Asked again who made the appointment. He said he did not know and there were about 3 other appointment on his schedule for that day with the same issue. He said he better call these people to make sure they know about the appointments. I leave to go home and notice how smooth the car is driving. There is better acceleration. Real time fuel economy seems higher. So far I have not had the startup rattle yet. Hope this takes care of it. Oh, the part#s used were 83 and 84 and they reprogrammed the ECM. I already had the oil changed at 2500 about two weeks earlier.
 

·
Registered
Joined
·
949 Posts
WTHUNTER said:
Received my recall (11195) September 1st. Went on line to google issue and found this thread. I remember having the startup noise about 3 times since the 5 months of ownership that other people were having. I decided that I will call and set up an appointment with service for Monday morning. Sunday night the wife says oh you have an appointment set up for tomorrow at 9:00am. for service on the equinox. I said no! She says yes, they sent you an email reminder for on 9/6/11 @ 9:00am. I said I never made an appointment but I was going to call them. Sure enough appointment was scheduled with out me even picking up the phone. Well that's to weird!!!!!! Monday morning comes around and I call and give my name and tell them I have an appointment set up for 9:00am and ask whats up. The service tech says what do you mean. I said I never made an appointment but I was going to call. They had no clue who made the appointment. I said that's funny I will keep the appointment it's my off day. I said do you have the parts needed for the job. He said hang on I will check and call you back. He calls me back and says yep, the parts dept has your parts with your name on them. OK this is really getting weird. I said ok see you at 9:00. Went in and it took about 1.5 hours while I waited. Asked again who made the appointment. He said he did not know and there were about 3 other appointment on his schedule for that day with the same issue. He said he better call these people to make sure they know about the appointments. I leave to go home and notice how smooth the car is driving. There is better acceleration. Real time fuel economy seems higher. So far I have not had the startup rattle yet. Hope this takes care of it. Oh, the part#s used were 83 and 84 and they reprogrammed the ECM. I already had the oil changed at 2500 about two weeks earlier.
Sounds great! Update us if anything unusual happens!
 

·
Registered
Joined
·
1 Posts
I have a 4 cyl..AWD 2011 terrain, first off milage sucks... 2nd problem is the car feels like its running too rich,, sometimes when letting off the gas pedal then giving it gas again it feels like its going to stall out, it just bogs down... also if going around a corner and you give it gas.. it does the same thing.... I never had a 4 cylinder before, but I have rented japanese cars with a 4 cylinder and they had some pep, never the issues I have with my terrain.. does anyone else have this issue?
Yes! I have a 2012 & have been trying to get to the bottom of this issue for at least TWO years! I have replaced both catalytic converters, oxygen sensors, spark plugs & wires; you name it. It is still doing this! When I take it to dealership where I bought it they can’t “reproduce the problem” to diagnose! Finally had a recall on O2 sensor that got done but engine light came back on throwing cat code again. Replaced spark plugs AGAIN per mechanics recommendation. STILL having issues! I am at my wits end!!
 

·
Registered
Joined
·
10,548 Posts
JM, you have a lot of stamina. I would have traded it in awhile ago.
 
1 - 12 of 12 Posts
Top