GMC Terrain, Equinox, and SRX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
After work, I started my Terrain and noticed the HVAC wasn’t turning on and up. I then had lights sporadically turning on and off. Brake, ABS, traction control, engine lights would blink along with a Stabillitrak, Tire Monitor, Blind Spot, or Backup Sensor DIC warnings (take your pick). Then would go back to normal and everything would be fine for 30 seconds and start all over.

When applying my turn signal, I could see my reflection in the tailgate of the truck in front of me and my signal was blinking normally. But the interior indicator was on solid for about 2 seconds, would disappear for 1-3 seconds, then come back on solid.

HVAC would be working fine and then completely die. The whole HVAC panel went dark when the fan shut down, then it all came back.

My tach, temp, fuel, and speedo gauges would die for half a second then come back to life, accompanied by random cluster lights and HVAC cutting out.

What the hell is happening? Has anyone else encountered this? Could it be the beginning of my alternator failing?

Any insight is helpful. Thanks.
 

Attachments

·
Registered
Joined
·
311 Posts
The first culprit i would try an nail down is the Battery. A bad or getting there battery causes all kinds of crazy things to happpen. Get the Battery properly tested and you will be on your way to finding out the problem if not solving it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
The first culprit i would try an nail down is the Battery. A bad or getting there battery causes all kinds of crazy things to happpen. Get the Battery properly tested and you will be on your way to finding out the problem if not solving it.
Thanks for the reply! I just put a brand new battery in it just before winter so it’s likely not the battery unless it’s defective.
Some other observations I’ve made:
The Terrain was sitting in a hot parking lot for 8 hours in 80-90° heat before this weird stuff occurred. After sitting in my garage for several hours and then driving it again this evening, there were no issues.

Do these additional details paint any other picture?
 

·
Registered
Joined
·
311 Posts
If it does not happen again then put it down to a Big Glitch, if it does, i would still start with the battery and check its cables, maybe one is loosening up. Next do a full deep scan on the vehicle through all four computer systems, B,C, P, and U. (Body, Chassis, Powertrain, Communications) and see if anything pops. At the temp you mentioned, that would qualify as a cool day in Arizona or La, or Texas where these vehicles do spend quite bit of time so the temp may not be a factor. See how it goes and let us know what you find, good luck
 
1 - 5 of 5 Posts
Top