GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My light on my dash came on service stabilitrak. What could this servicing consist of like new parts a bad sensor? Cost?
 

·
Registered
Joined
·
1,106 Posts
what model, year, how many miles would help..
 

·
Registered
Joined
·
1,106 Posts
Is it bitterly cold where your at?..sensor(s) or mechanical freeze up?
 

·
Registered
Joined
·
1,106 Posts
unless you went from wet to frozen, probably not that..thats not too cold..

still thinking a sensor issue..

if you can get an engine service code reader (OBD II ) and see what codes its throwing might help you figure out whats going on.
 

·
Registered
Joined
·
2,772 Posts
Cwish said:
My light on my dash came on service stabilitrak. What could this servicing consist of like new parts a bad sensor? Cost?
I would recommend contacting your local dealer for more assistance. Please keep me posted on your progress. I can also look into this for you with the last eight of your VIN. Feel free to contact me privately. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
5 Posts
I have a 2011 AWD Terrain with 60,000 km on it. Today the "Service Stabilitrak" light came on, and the "Service Engine" light. It has started idling roughly, and feels like it will stall. Turning off the "ECO" button seems to improve the RPMs so it doesn't sound like it will stall.

Have an appointment with a dealer in 2 days, but have to use it to commute 200 km a day for today & tomorrow until then. Hopefully nothing too serious going on.
 

·
Registered
Joined
·
673 Posts
jfindlay said:
I have a 2011 AWD Terrain with 60,000 km on it. Today the "Service Stabilitrak" light came on, and the "Service Engine" light. It has started idling roughly, and feels like it will stall. Turning off the "ECO" button seems to improve the RPMs so it doesn't sound like it will stall.

Have an appointment with a dealer in 2 days, but have to use it to commute 200 km a day for today & tomorrow until then. Hopefully nothing too serious going on.

Sounds like it went into safe mode/limp mode.
 

·
Registered
Joined
·
2,828 Posts
Cwish said:
08 lt 112,000 miles
If Service Stabilitrac light is on but not in conjunction with the ABS (ABS lite is not on) it could be the sensor in the steering column and not the sensors in each rotor assembly. If the BCM doesn't know which direction the steering wheel is postioned, it will disengage the Stabilitrac.

The GM computer at your dealer will be able to tell which one.

[/color]
 

·
Registered
Joined
·
5 Posts
Took it into a dealer for service, and they said the crankcase was full of fuel, had to replace fuel pump, change oil as there was fuel in the oil. I'm no mechanic but ti sounds like something that could cause further problems.

Not sure what that had to do with the stabilitrak warning light, but it was an $800 bill that was luckily covered by warranty (this time).
 

·
Registered
Joined
·
5 Posts
jfindlay said:
Took it into a dealer for service, and they said the crankcase was full of fuel, had to replace fuel pump, change oil as there was fuel in the oil. I'm no mechanic but ti sounds like something that could cause further problems.

Not sure what that had to do with the stabilitrak warning light, but it was an $800 bill that was luckily covered by warranty (this time).
At about 75,000 km now (was at 60,000 last time there was this issue), and the Terrain is idling rough again. Took it into a dealership last week & they charged me $100 to check it, no codes came up, so they said they couldn't do anything. Two days later, the "check engine" light is on. Not really looking forward to another trip to dealer, another day without a vehicle, and at least $100 just to plug it into the computer. Starting to doubt the quality of this vehicle.
 

·
Registered
Joined
·
483 Posts
On our 2011 Equinox the Service Stabilitrak message came on at every startup with just 300 miles on the odometer. It turned out to be the sensor in the steering column.

Just turned 20,000 miles and the only other problem with the vehicle has been a drivers side rear power window regulator that was replaced about a month ago.

I'm very pleased with our LTZ.
 

·
Registered
Joined
·
2,772 Posts
jfindlay said:
At about 75,000 km now (was at 60,000 last time there was this issue), and the Terrain is idling rough again. Took it into a dealership last week & they charged me $100 to check it, no codes came up, so they said they couldn't do anything. Two days later, the "check engine" light is on. Not really looking forward to another trip to dealer, another day without a vehicle, and at least $100 just to plug it into the computer. Starting to doubt the quality of this vehicle.
Are you located in Canada? Have you been in contact with GM of Canada at 800-263-3777. The hours of operation are M-F 7:30am - 11:30pm, Sat 7:30am - 6:00 EST. Please feel free to keep me posted or contact me with further questions. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
196 Posts
jfindlay said:
At about 75,000 km now (was at 60,000 last time there was this issue), and the Terrain is idling rough again. Took it into a dealership last week & they charged me $100 to check it, no codes came up, so they said they couldn't do anything. Two days later, the "check engine" light is on. Not really looking forward to another trip to dealer, another day without a vehicle, and at least $100 just to plug it into the computer. Starting to doubt the quality of this vehicle.
Consider buying your own OBDII code reader, just plug in to check your own code, or pending code issue. Can be reset as well. I think they are down to well under $50. The higher cost Code readers do alot more than just read back.
 

·
Registered
Joined
·
2 Posts
I have a 2011 terrain and two weeks ago my service stabilitrak light came on and brake fluid low light came on. Both at the same time and every time I start my car. Last week the service engine light came on, had a friend see what code it was and was for my o2 sensor. Cleared that and still the stabilitrak and brake fluid light come on each time I start the car. I have 80,000 miles on the car so no warranty anymore, so wondering if anyone knows what I can do that is cheaper? Also the brake fluid is not low. I have checked that. So not sure why it still keeps coming on. Any help would be appreciated. My battery just died 3 weeks ago and was changed not sure if that would affect anything as well. Thanks!
 

·
Registered
Joined
·
10,525 Posts
Zoog299 said:
I have a 2011 terrain and two weeks ago my service stabilitrak light came on and brake fluid low light came on. Both at the same time and every time I start my car. Last week the service engine light came on, had a friend see what code it was and was for my o2 sensor. Cleared that and still the stabilitrak and brake fluid light come on each time I start the car. I have 80,000 miles on the car so no warranty anymore, so wondering if anyone knows what I can do that is cheaper? Also the brake fluid is not low. I have checked that. So not sure why it still keeps coming on. Any help would be appreciated. My battery just died 3 weeks ago and was changed not sure if that would affect anything as well. Thanks!
By "cleared that", do you mean that you replaced the faulty O2 Sensor ? If so, then you can clear the codes by disconnected the battery for 10 or so minutes, and that should clear the CEL and other warning lights, and they should not come back on - unless you replaced the wrong O2 Sensor.
 

·
Registered
Joined
·
1 Posts
My wife had the same problem with the Stabili Trak Light going off on a cold start. just brought it to the dealership and ran on the computer. My salesman told me its the "Speed Sensor ABS". the brakes will work but will not have the anti lock brakes system available until replaced. $259.72 for parts and labor.

Good luck-
 

·
Registered
Joined
·
1 Posts
I have a 2012 trerrian with 83,000 Miles my service stability track light came on had OnStar check gave code of u0401 issue has been detected in the antilock brake system. My question is it ok to drive to repair shop. When I turned it off and back on light went off.
 
1 - 20 of 22 Posts
Top