GMC Terrain, Equinox, and SRX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter · #1 ·
Got a 07 SRX V8 but its just that whenever it hits a bump or something it just make a squeeky noise in the interior (towards the back of it i think it's the backseat) told the repairmen fix it several times but it's still happeneing... I don't know what i can do
 

·
Registered
Joined
·
748 Posts
Dont think you have the same platform as the newer models, but you may want to check the parking brake cable and bracket. A few people, myself included, have heard a "squeak" from the left rear of the car. Right under the left rear door in front of the wheel. Get him to check, grease, and re-locate the bracket. Might solve the problem.
 

·
Registered
Joined
·
977 Posts
My nosie was from the 2 brittle plasic coverings on the cables rubbing each other. Was easily fixed by myself. The dealer couldn't figure it out.
 

·
Registered
Joined
·
830 Posts
Maybe body flexion, you can try to put somme sillicone spray over the rubbers all over the car.
 

·
Registered
Joined
·
977 Posts
I just wrapped one of the tube with some rubber heater hose (I slit the heater hose) so the 2 hard plastic coverings over what appears to be the brake cables don't rub. The noise I had was on the rear drivers side. When it rained you didn't hear it. The cable covers and the bracket are a poor design.
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #6 ·
i thought it might be the screw is loosing and tried to screw it back up... it went good except few days later it comes back again
 

·
Registered
Joined
·
748 Posts
RNOX said:
I just wrapped one of the tube with some rubber heater hose (I slit the heater hose) so the 2 hard plastic coverings over what appears to be the brake cables don't rub. The noise I had was on the rear drivers side. When it rained you didn't hear it. The cable covers and the bracket are a poor design.
Mine only made noise after it rained and the car started to dry. Needless to say it would always go away by the time I got a dealer appt. They finally fixed it after I insisted AND pointed out exactly where it was coming from and what i read about the cables and bracket. Coincidence? I think not...
 

·
Registered
Joined
·
977 Posts
Phantm006 said:
Mine only made noise after it rained and the car started to dry. Needless to say it would always go away by the time I got a dealer appt. They finally fixed it after I insisted AND pointed out exactly where it was coming from and what i read about the cables and bracket. Coincidence? I think not...
Mine I took to the dealer on a rainy day. Both the tech and the serrvice manager drove the vehilce and no noise (I didn't hear it going to the dealer). Said to bring in next time i Heard. Dry day tech heard the noise (I drove with him) said bring in for an appt. Claimed it was a loose brake clamp and fixed. Still made the noise. So I looked and noticed when I rubbed the hoses it made the squeaking. No noise anymore since I installed the heater hose
 
1 - 9 of 9 Posts
Top