GMC Terrain, Equinox, and SRX Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
dealer says vehicle needs rear object detection modules and harness due to modules being corroded and dropping the low speed gm lan line cuasing radio and dash messages p/s gas guage stuck on full rear hatch stopped openng front cam ot working all started at same time if i buy new module and harness is it just plug and play i keep hearing about having them programed idk if there confusing it with the body module which i think needs to be programed thank 2013 gmc terrain denali
 

· Registered
2011 Equinox 1LT V6 3.0L FWD 182k miles
Joined
·
4,736 Posts
Try searching this Forum for “camera” and read some of those Threads. One of the best things about having a 10-year-old vehicle is ... someone’s already been through the problem you’re having, and they likely found a solution.

I’d look myself, but it’s really late and I need to “turn in” (as they say) ... LOL!
 

· Super Moderator
Joined
·
1,856 Posts
Let the dealer fix it. GM parts also come with a 2 yr warranty.
They know more about the system, and they supplied you with a ton of information on your problem. Many replacement modules have to be ''married'' to the vehicle. On here unless someone has gone through your exact problem it is a guess.
 
  • Like
Reactions: ricklack

· Registered
2011 Equinox 1LT V6 3.0L FWD 182k miles
Joined
·
4,736 Posts
@bigted4201 : My question is: how the heck do Modules get corroded? These things are fairly well protected from that kind of thing, I think. Maybe try cleaning the connections with some of that Electrical Connector Cleaner, and unconnecting/re-connecting the plug(s) a few times?

After that, if it still wasn't working, but there appeared to be a signal at the existing Camera, I might try picking up a used Camera from the junkyard for $50-$60 (which would be half the price of a brand new one from GMPartsDirect.com) ... to see if that did it.

Relatively little money spent with a decent chance at fixing the problem and avoiding a (likely) $300+ bill at the Dealership...
 

· Registered
2018 Terrain Denali 2.0T FWD
Joined
·
286 Posts

· Super Moderator
Joined
·
1,856 Posts
I had salt creep into my rear camera in my '11 Tahoe. Salt is evil stuff. Camera was NLA from GM, got lucky on Fleabay with one from a western JY.
 
  • Like
Reactions: Colt Hero
1 - 8 of 8 Posts
Top