GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
What I'm seeing with my stereo is when I turn on my vehicle all the FM channels will be static / snow. Switching to XM, those channels are fine. It doesn't change if I simply turn off the radio, I have to turn off my vehicle and open the driver's door, then restart. When I restart its fine. I've taken my 2010 Terrain into the dealer to see if they could find what causes this. They said updated the firmware and called GM. Just putting this out there to see if anyone else is experiencing this and more importantly if they found a solution.
 

·
Registered
Joined
·
626 Posts
Strange. Sounds like you are close enough to FM stations to get clear reception and it's just intermittent?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Yeah, its weird. I've tried leaving the radio on FM, XM, or Hard-Drive when turning off the vehicle to see if I can reproduce it but no luck. I can find no rhyme or reason to it.
 

·
Registered
Joined
·
2 Posts
I've had my 2011 Terrain for less than a week and had my first "All Static" experience on FM stations only. It wasn't until I turned off the engine and opened the drivers side door, that the system reset and everything started working again.

The only other issue I encountered was after trying to input a NAV destination via voice recognition, the unit froze and reset on it's own.
 

·
Registered
Joined
·
43 Posts
BlackCracker said:
I've had my 2011 Terrain for less than a week and had my first "All Static" experience on FM stations only. It wasn't until I turned off the engine and opened the drivers side door, that the system reset and everything started working again.

The only other issue I encountered was after trying to input a NAV destination via voice recognition, the unit froze and reset on it's own.
I had this exact same static issue today. It was about 35 degrees F outside, I drove about 1 mile and stopped for gas. When I restarted the Equinox all FM stations were static. I tried turning off the radio but that did nothing. I turned off the vehicle, opened the driver's door, restarted and all was fine.

Has anyone had this happen more than once or gone to the dealer with this issue?
 

·
Registered
Joined
·
1 Posts
I am having issues as well. I live in a pretty rural area, but my old 2003 Taurus would get about 10 FM channels very clearly. My 2011 Equinox will 'seek' only 4. All the others are static. If I try to 'dial' to my fav station (Bob & Tom) - I get mostly static. The only time it comes in somewhat clear is when the XM is blocked (in the garage or under a bank drive-up awning)... Will GM service be able to fix this?
 

·
Registered
Joined
·
2 Posts
Have a 2011 SLT1 with the random FM static issue at start up but it fixes if I turn off and open door to totally disengage the radio. Dropped it off at the dealership today.....lets see what they say. I had thought it was with the ignition, but not sure.
 

·
Registered
Joined
·
626 Posts
DAS said:
lets see what they say.
Prediction: "cannot confirm customer complaint, unit operates normally."
 

·
Registered
Joined
·
48 Posts
Hmmm... I had this same exact thing happen a couple of weeks ago. Just got in the car and had pure static on EVERY station.
Turned car off at home. Next startup was perfectly normal.
To be clear, I was in a perfectly fine area..I searched all channels and got nothing except a faint possible broadcast on one but mostly static. All others were just loud static.

I'll mention this when I have it in tomorrow for the tight wheel tilt adjust and look at "updating" whatever it takes to fix the way it doesn't go back to whatever it last was playing when the car is turned off....randomly.
 

·
Registered
Joined
·
33 Posts
There is another topic in this forum where the owner had to get a new mod or something it took awhile for the dealer to agree something was wrong with the radio. I think it was under what's wrong with the equinox but not sure. This guy it switched sometimes it was the xm and sometimes the fm, then another person was saying if your driving along out in the open and your signal for the xm goes in and out that's also a sign your radio has that problem.
 

·
Registered
Joined
·
2,772 Posts
jecilop said:
Hmmm... I had this same exact thing happen a couple of weeks ago. Just got in the car and had pure static on EVERY station.
Turned car off at home. Next startup was perfectly normal.
To be clear, I was in a perfectly fine area..I searched all channels and got nothing except a faint possible broadcast on one but mostly static. All others were just loud static.

I'll mention this when I have it in tomorrow for the tight wheel tilt adjust and look at "updating" whatever it takes to fix the way it doesn't go back to whatever it last was playing when the car is turned off....randomly.
I am glad to see that you are planning to work with your local dealer. Please feel free to keep me posted. Thank you in advance.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
2 Posts
I had this problem many times on my 2010 equinox. It's totally random.

I also have another problem. On my favorite station I get in and out static terribly to the point I can't make out any words. The dealer confirmed the issue and has replaced the radio 3 times and the antenna twice. The reception on the fav station is perfect for a couple of weeks and then it starts to fade again to the point i can't make out any words. It's not an issue with the distance to the tower since every other car I'm in never has an issue - crystal clear.

What gives GM? After the last radio replacement my warranty is out and now I'm stuck?

It also seems that the dealer really didn't do any troubleshooting. The radio was replace 3 times and it happened again 3 times. According to my book that's the definition of insanity.

Anyone else in the same boat?

GM, are you listening?
 

·
Registered
Joined
·
10,510 Posts
rymiller said:
GM, are you listening?
"Sounds like" (pun intended) GM is having bad reception on your "broadcast" !

:banghead:
 

·
Registered
Joined
·
1 Posts
I ahve had my 2012 Terrain in the shop 4 times now, I was told the last time that some degree of static is normal. Hmm, well, I now drive down the road playing my radio while videotping the static on full blast, I would call it music but since all I hear is PURE static at most times thats what I will call it.. Took it back today, and played the video footage to the service advisor and also to the tech, they re callibrated it, said the calllibration was wrong, I was super excited that they finally found an answer, pulled out of the garage there and it was back to the usual crap! ON top of that weird things have been happeneing, NONE iof which can be found or re created, The screen freezes up , it says diualing, I am not using the phone at the time or it freezes on please try again, Um, try WHAT again, I am driving and just started my car.. also, my screen goes very dim all of a sudden like if u were to turn down the dimmer switch but I havent touched the switch and it doesnt come back until i turn car on then off. Alaso, my car feels like it is going to stall then it jerks real hard, they cant find that either.. It gets so frustrating..
 

·
Registered
Joined
·
10,510 Posts
bam320

I would apply for the Lemon Law in your State. Seems like you have giving them more than enough chances.
 

·
Registered
Joined
·
748 Posts
They gave me a 2014 Enclave as a loaner a few weeks ago. One weird thing I noticed was that every few minutes or so the radio would repeat itself. Like it was rewound and would play back the last 5 or six seconds of whatever I was listening to. That was really weird.
 

·
Registered
Joined
·
2,772 Posts
bam320,

This does sound frustrating. Can you please private message us your name, VIN, phone number, and the name of your GMC Dealership? I would like to look into this further for you.

Erica Tiffany
GMC Customer Care
 

·
Registered
Joined
·
1 Posts
I just purchased a 2011 GMC terrain SLT a couple of months ago and I am having the same issue. When I turn my car on the FM stations have nothing but static. As soon as I turn the truck off then back on the radio then comes back on normal. It seems as though many people are having this issue and no bulletin has been set up to correct the problem. I am hoping that GM reads this and try's to figure out an action plan because from the looks of all these posts its an on going issue with these vehicles.
 

·
Registered
Joined
·
2,772 Posts
MYLENE1 said:
I just purchased a 2011 GMC terrain SLT a couple of months ago and I am having the same issue. When I turn my car on the FM stations have nothing but static. As soon as I turn the truck off then back on the radio then comes back on normal. It seems as though many people are having this issue and no bulletin has been set up to correct the problem. I am hoping that GM reads this and try's to figure out an action plan because from the looks of all these posts its an on going issue with these vehicles.
Hi MYLENE1,

We understand your frustration radio static and apologize that you're experiencing this. If you'd like for us to document this issue within our system for future reference please feel free to PM us your name, VIN, mileage, contact info and dealership.

Amber N.
GMC Customer Care
 

·
Registered
Joined
·
163 Posts
I bought a 2012 Equinox less than a week ago, wife complains the FM isn't no where as good as the reception she had in her 2005 Aztek, and we actually get pretty good radio up here in Alaska where I live in Wasilla. I told her to call the chev dealer and say this isn't right.
 
1 - 20 of 27 Posts
Top