GMC Terrain, Equinox, and SRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought my SLT1 with navigation last month and have had radio issues since the beginning.
1. When playing music from the hard drive, only when I first turn the car on, it skips about 25 seconds into the song.
2. The rear view camera sometimes show with purple lines on the screen.
3. The FM radio did not work one time, all the stations were static. Once I restarted the car, they worked again.
4. About 30% of the time, the ipod does not work.

I took it in 3 weeks ago, they said they had to call another department, some technical assistance number, went back today because I had not heard anything, they asked me to drop the car off because they need to get some numbers of the unit. I just don't want any squeaks or rattles when they pit it back together.

Any one else having radio problems?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
UPDATE: Radio Problems

just got it back from the dealer. They told me they spent 3 hours talking with the GMC engineers, no fix at this time. Told me it may take months. Needless to say, not happy with GMC and the way they stand behind their products.

You think they would just swap out the radio.

Luckily, we have a Lemon Law in Florida, I'm going to pull the book out and read what needs to be done.
 

·
Registered
Joined
·
2 Posts
Having a similar experience with nav system in my Equinox. Different symptoms, same response from GM.

Here's what I've been getting:
1. If the stereo is playing from the hard drive when I turn the car on, 50/50 chance the song will skip and stutter for about 5 seconds. I suspect this has something to do with the car-puter not having enough processing power to handle music playback, satellite acquisition, and the initial XM traffic/weather update all at once.
2. Also on start-up, the nav system defaults back to the warning / disclaimer screen, even if I wasn't using it when I turned the car off. Not a big deal really, except it only started doing this in the last month or so.
3. In the same vein as No. 2, the nav system doesn't seem to be able to remember my elevation and display settings, and defaults back to a 2D view from 700ft.
4. Ipod, or rather, Iphone 3g, occasionally won't work; or charge. Only way to fix this is to restart the car.
5. The car seems to have 3 or 4 favorite songs on the harddrive, and for a while would play one of them on start-up, no matter what was playing when the car was turned off.

I took it back to the dealer and they were able to correct Nos. 1, 4 & 5, but no dice on 2 & 3. It took them two visits. The first was to diagnose the problem with GM engineers and order DVD software update, and the second was to actually update the software.

I'm going to try a different dealer for a second opinion.

Coincidentally, I'm also in Florida, so I've got the lemon law fallback as well. It's a shame to even consider it, though, since I really do love the car.
 

·
Registered
Joined
·
1 Posts
2017 Terrain radio static issues

I bought my SLT1 with navigation last month and have had radio issues since the beginning.
1. When playing music from the hard drive, only when I first turn the car on, it skips about 25 seconds into the song.
2. The rear view camera sometimes show with purple lines on the screen.
3. The FM radio did not work one time, all the stations were static. Once I restarted the car, they worked again.
4. About 30% of the time, the ipod does not work.

I took it in 3 weeks ago, they said they had to call another department, some technical assistance number, went back today because I had not heard anything, they asked me to drop the car off because they need to get some numbers of the unit. I just don't want any squeaks or rattles when they pit it back together.

Any one else having radio problems?
I too have problems with my 2017 Terrain radio. The static is just awful. I took the car to the dealership and the Service Manager "Warren McCaskey at Morris GMC in North Olmsted Ohio said this has been a normal problem and there is no fix. So after spending $35,000 for a car and this dealer Service Manager said "it is what it is"

Anyone have an idea who at GMC I could contact?
 
1 - 4 of 4 Posts
Top