GMC Terrain, Equinox, and SRX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
When I bought my SRX the radio worked like every other car I have owned. If the radio was powered "on" when you turned the car off then it would come back "on" when you started the car an hour or so later (after the car had powered down). In the last couple of weeks I have to push the power button to turn the radio "on" every time I start the car (after the car has powered down). I have had it into the dealer 3 times and they say that is the way it is supposed to work but I am skeptical. It didn't use to work that way nor has any other car I am aware of work that way. Has anyone else experienced this problem or is it just me. They recently did a software update which they said would fix the issues with the radio but nothing has changed.
 

·
Registered
Joined
·
10,522 Posts
Based on this comment, and your one about the hard drive, sounds to me like your stereo has alzheimer's disease - it has lost its memory function. Does it remember your presets ?
 

·
Registered
Joined
·
119 Posts
RIT333 said:
Based on this comment, and your one about the hard drive, sounds to me like your stereo has alzheimer's disease
Haaaa!! Great! Made my day! lol
 
Joined
·
24 Posts
jimallyn,

What is the model year of your SRX?

Caron, Cadillac Customer Service


jimallyn said:
When I bought my SRX the radio worked like every other car I have owned. If the radio was powered "on" when you turned the car off then it would come back "on" when you started the car an hour or so later (after the car had powered down). In the last couple of weeks I have to push the power button to turn the radio "on" every time I start the car (after the car has powered down). I have had it into the dealer 3 times and they say that is the way it is supposed to work but I am skeptical. It didn't use to work that way nor has any other car I am aware of work that way. Has anyone else experienced this problem or is it just me. They recently did a software update which they said would fix the issues with the radio but nothing has changed.
 

·
Registered
Joined
·
10,522 Posts
I've said it before, but I'll say it again. I am VERY impressed that customer service reps are reading this forum, and offering help.

It said alot for GM, and it also says alot for the credibility of this forum.

Quodos to both !
 

·
Registered
Joined
·
196 Posts
RIT333 said:
I've said it before, but I'll say it again. I am VERY impressed that customer service reps are reading this forum, and offering help.

It said alot for GM, and it also says alot for the credibility of this forum.

Quodos to both !
i have this feeling it is a bot or something like that...and not real customer service..escpecially with only 2 posts.

just me though...
 
Joined
·
24 Posts
jimallyn,
Do you know if the dealership has involved our Technical Assistance Center (TAC)? If they have not, I would encourage you to inquire with your dealership about getting them involved. If the dealership has already involved TAC maybe it would be advisable to go to a different dealership. If you want to remain with this dealer please let me know. We will contact the dealership about this issue.

Caron, Cadillac Customer Service


jimallyn said:
It is a 2010. The dealer just reprogrammed the radio as per bulletin 2517977 but nothing changed.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
I do not know if my Cadillac dealer (Silver Star Cadillac in Thousand Oaks, CA) contacted the TAC. I suspect not since they claim there is no problem. The reason I posted to this forum is because I believe there is a problem and I wanted to see if other SRX owners were having this same problem. I contacted Cadillac Owners Assistance in Detroit and they have been researchng it for me. Anything anyone can do will be helpful and thanks in advance.
 
1 - 10 of 10 Posts
Top