GMC Terrain, Equinox, and SRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys, new to the forum but looks like this is the place to get answers for the Equinox. I was driving down the road in our 2005 Nox and started to lose power and lots of white smoke was pouring out the tailpipe. Pulled over and checked the oil and it was frothy and milky brown. A while back I noticed the coolant was low (Engine Cool) but hadn't been leaking out so I fille dit to the cool level when the motor was cool and that seemed to be fine. Then today I had this problem. Had it towed to the house and figured it must be a head/Intake gasket or cracked cylinder head, haven't had it overheat in the past that I can remember but the other day was sitting in a drive thru and the coolant temp guage got up close to the H and then the fan kicked in and the needle went down rapidly. This was when I found the coolant to be low.

Any thoughts guys? Thanks for the help.
 

·
Registered
Joined
·
1,082 Posts
LIM gasket failure. You can find tons of walk through online. Fairly common on the 3400 engines.

Are there tear drop type stains on the heads? If so, you more than likely, have a LIM failure.
 

·
Registered
Joined
·
482 Posts
The common problem with the LIM gasket was corrected sometime in 2003 with a new part (doesn't mean there couldn't be an occasional failure with new one though :) )
 

·
Registered
Joined
·
1,082 Posts
Terra-Nox said:
The common problem with the LIM gasket was corrected sometime in 2003 with a new part (doesn't mean there couldn't be an occasional failure with new one though :) )
Not really. On the Grand Am board I frequent a girl just had one fail on her 2005 GA with 60k miles. The stock new gasket is better but it still fails time to time. Only fix is to put the Felpro forever fix gasket kit in it.

I do agree that the 2003 and up cars had far less failures but they are still out there especially on the Equinox and Torrent.
 
1 - 5 of 5 Posts
Top