GMC Terrain, Equinox, and SRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My father and I were troubleshooting some headlight issues and we were checking fuses, relays and bulbs. Turns out all of those were fine, but now it won't start. The clock reset itself to 12:00, is it possible we ran the battery so low it won't start? It doesn't want to be jumped by my portable jump starter. Also, what is the sensor mounted behind the mesh part of the grille? We knocked it out but put it back in its little holder. Anything else we can possibly troubleshoot?

It's an 05.
 

·
Registered
Joined
·
10,406 Posts
Might that sensor be for outside temperature ?
 

·
Registered
Joined
·
949 Posts
Are you 100% sure that you put all of the fuses back in correctly? That's my only guess.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Yes, the fuses we took out then put back in, and we only swapped relays that were the same type like the horn in place of the headlights, and they all worked. Is it possible the battery got so low that it can't even be jump started now? The electric is so dead it can't even move the windows anymore.
 

·
Registered
Joined
·
2,271 Posts
Dest said:
Yes, the fuses we took out then put back in, and we only swapped relays that were the same type like the horn in place of the headlights, and they all worked. Is it possible the battery got so low that it can't even be jump started now? The electric is so dead it can't even move the windows anymore.
When you went to jump the vehicle did you put both cables on the "dead" battery? if so you may have fried some electronics...
 

·
Registered
Joined
·
949 Posts
If you have something like a battery charger, or one of those jump-start batteries, where you can see the current voltage of the battery, check that out and see what the voltage is. If it's too low, and you can't charge it back up to the right voltage, then I would think the battery is bad now.
 
1 - 7 of 7 Posts
Top