GMC Terrain, Equinox, and SRX Forum banner
21 - 30 of 30 Posts

·
Registered
Joined
·
1 Posts
I am renting a 2020 and this morning same thing no blinker or radio no noises at all. I just went outside and tried pressing the instant button while in reverse and IT WORKED!! All the sound is back now!
 

·
Registered
Joined
·
1 Posts
UPDATE: Went to the dealer this morning. The guy plugged his diagnostic tool in and pushed the On-Star button while the car was in reverse. Magically, the On-Star voice came through the speakers and all sound returned. He told me something happened to cause the system to hang in limbo. Pushing the On-Star button with the car in reverse resets the connection between the console and the speakers. It was nothing hardware related. I was in and out in literally 10 minutes.

Hope this helps someone out there.
TY for saving ma a trip to the dealer.....WORKED on a 2015 Sonoma too!
 

·
Registered
2019 Terrain SLE AWD 1.5
Joined
·
139 Posts
Isn't the blinker fluid tank right next to the bumper bearings?
 

·
Registered
Joined
·
1 Posts
I started my 2014 Terrain up this morning to find that the stereo system is completely broken. I cannot get sound out of my speakers from any inputs; AM/FM radio, USB, XM, nothing produces sound. I also notice that my blinker sounds to not have the "tick" noise anymore. No backup sensor warning noises either. The center console, all dash lights, everything else works perfectly. I can see what's playing on the stereo, the clock is right, etc.

Seeing as this is a holiday weekend, I don't have any hope of getting to a dealer until next week.

Has anyone else experienced this? Have any quick fixes for me to try? If anyone has had this and solved it - what should I tell the dealer to look at?
I will give this a try. My 2014 GMC started doing this in 2016 and the dealership updated the radio or something. Well, its happening now again. Its random though sometimes it works and sometimes nothing. Other times the sounds/radio will work on and off while driving. Its very annoying.

I will try the key on, reverse and hit Onstar. We'll see what happens I guess. If I take it to a GMC dealer its gonna be 149.99 just to do an initial diagnostic test.. If that doesn't work I will try and locate that 30 amp fuse someone had mentioned.
 

·
Registered
Joined
·
2 Posts
For future reference, I turned the key but did not start the car.
Put it in reverse, pushed the onstar button multiple times. I even held it in for 10 seconds or so at one point.
Nothing was happening sound wise.
I noticed on the screen there was an option to "hang up" the onstar call.
I selected the option to hang up.

I then put the car back in park, turned the key off. Then started the car.
Suddenly the radio came on and the seat belt chime was dinging.
The problem was resolved. All thanks to Pianoman.

-2015 Chevrolet Equino
 

·
Registered
Joined
·
2 Posts
For future reference, I turned the key but did not start the car.
Put it in reverse, pushed the onstar button multiple times. I even held it in for 10 seconds or so at one point.
Nothing was happening sound wise.
I noticed on the screen there was an option to "hang up" the onstar call.
I selected the option to hang up.

I then put the car back in park, turned the key off. Then started the car.
Suddenly the radio came on and the seat belt chime was dinging.
The problem was resolved. All thanks to Pianoman.

-2015 Chevrolet Equinox
I did exactly this on my 2014 Equinox and it worked! Thanks for saving me a trip to the dealership!
 

·
Registered
Joined
·
1 Posts
I started my 2014 Terrain up this morning to find that the stereo system is completely broken. I cannot get sound out of my speakers from any inputs; AM/FM radio, USB, XM, nothing produces sound. I also notice that my blinker sounds to not have the "tick" noise anymore. No backup sensor warning noises either. The center console, all dash lights, everything else works perfectly. I can see what's playing on the stereo, the clock is right, etc.

Seeing as this is a holiday weekend, I don't have any hope of getting to a dealer until next week.

Has anyone else experienced this? Have any quick fixes for me to try? If anyone has had this and solved it - what should I tell the dealer to look at?
Did you ever find a fix?
 
21 - 30 of 30 Posts
Top