GMC Terrain, Equinox, and SRX Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello all. My wife has a 2008 Chev Equinox. It has been a great vehicle so far, with minimal problems. One recently did creep up today though.

After turning on the car, she noticed that there was no radio (controls light up, screen stays blank - not even the time - and there is no sound.) Further, the turn signals work, but produce no sound and there are no door chimes, key in ignition chimes or any other vehicle generated noise in the interior.

I have come across a few older (2008 and 2010) topics on this same issue but no one has come back with a solution. Any ideas as to what this might be? With 2 young kids the radio is a must!! :)

Thanks in advance,

Greg
 

·
Registered
Joined
·
2,772 Posts
Greg,

Has your concern been resolved? I would recommend contacting your local dealer for more information. Please feel free to keep me posted via private message either way. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
1 Posts
Good luck getting this fixed. I have had this SAME problem on my 2010 Equinox since I bought it in august of 2009. :angryfire: It has been to the dealer at lest 16 times. GM has had case numbers pulled on it only to be told by the dealer that they can't duplicate the problem. I just took it in to the dealer just yesterday 8/30/11 with a non working Nav system/radio no sounds it was witnessed by the service consultant but he could not get a tech to look at it at that moment. I left it at the dealer and of course this morning when the tech looked at it they were unable to duplicate it. :banghead: The service consultant said the tech needed to verify a couple things before they could order the parts to fix it because Chevrolet would not replace the part without the tech seeing the problem firsthand. (I have recorded several of the instances on video)
 

·
Registered
Joined
·
949 Posts
notafan said:
Good luck getting this fixed. I have had this SAME problem on my 2010 Equinox since I bought it in august of 2009. :angryfire: It has been to the dealer at lest 16 times. GM has had case numbers pulled on it only to be told by the dealer that they can't duplicate the problem. I just took it in to the dealer just yesterday 8/30/11 with a non working Nav system/radio no sounds it was witnessed by the service consultant but he could not get a tech to look at it at that moment. I left it at the dealer and of course this morning when the tech looked at it they were unable to duplicate it. :banghead: The service consultant said the tech needed to verify a couple things before they could order the parts to fix it because Chevrolet would not replace the part without the tech seeing the problem firsthand. (I have recorded several of the instances on video)
Wow, you've let them have 16 opportunities to fix this? It's so frustrating that they have to witness problems like that, I mean it makes complete sense that they have to witness it, but I would say if it's been happening for 2 years and you have VIDEO PROOF of it, they would believe you. You might need to try a different dealer, I'm surprised they haven't fixed this yet for you, or even offered to replace the whole nav/radio system in an effort to fix it. You might start requesting that. I would be beyond frustrated at this point if I were you. Hang in there, hopefully they'll fix it this time.
 

·
Registered
Joined
·
2,772 Posts
notafan said:
Good luck getting this fixed. I have had this SAME problem on my 2010 Equinox since I bought it in august of 2009. :angryfire: It has been to the dealer at lest 16 times. GM has had case numbers pulled on it only to be told by the dealer that they can't duplicate the problem. I just took it in to the dealer just yesterday 8/30/11 with a non working Nav system/radio no sounds it was witnessed by the service consultant but he could not get a tech to look at it at that moment. I left it at the dealer and of course this morning when the tech looked at it they were unable to duplicate it. :banghead: The service consultant said the tech needed to verify a couple things before they could order the parts to fix it because Chevrolet would not replace the part without the tech seeing the problem firsthand. (I have recorded several of the instances on video)
I would like to look into this for you. Do you have your case number? Please feel free to contact me privately. Thank you in advance.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Thanks for the help guys. We took the vehicle into the local dealer who poked and prodded for a bit and came out with shrugged shoulders. The suggestions that they had to remedy the issue were all expensive and not promised to resolve the issue.

I ended up taking the vehicle to my father, who ended up messing around with the fuse box. After pressing and pulling fuses for a bit, the problem got better in the sense that the interior sounds would come back, go away, come back, go away.......but at least there were sounds. We took a look at the fuse box (located on the drivers side) and noticed that it appeared to be corroded. We cleaned up the connections as best we could and got better results but still, there was only sound some of the time. We replaced many of the fuses, with the same result.

We sourced a fuse box from a wrecked Equinox, replaced ours and voila. Problem solved!!

The fuse box was corroded and all "gummed up." The box out of my winter beater Chevy Celebrity looked newer. Dont ask me how that could happen because I have no idea. We keep the vehicle spotless and have owned it since new, with no water damage or anything of the sort.

If you have any specific questions, pls feel free to let me know. If you are having the same issue, I suggest playing around with the fuses to start. If there is not a good connection (loose, or fouled) it very well may be causing your issue.

Thanks again for all of the help,

Regards,

Greg
 

·
Registered
Joined
·
1 Posts
Re: No interior sound (radio, )

2012 Equinox What did you ever find out today our radio stoped today 12 local stations has no sound but cd will work crazy
 

·
Registered
Joined
·
1 Posts
Still not working correctly

Okay, I see this an old thread, but nothing out there comes as close... I bought a used equinox and the chimes did not work and the radio would skip a beat every three minutes. While performing some repairs that for safety sakes required disconnecting the battery for a few days I noticed that the chimes started working again after reconnecting the battery the radio also returned to normal operation. Cool! Well, it was brief. After about two weeks of normal operation, the chimes quit working again and the radio hiccup returned. I disconnect the battery again to test this as thinking it was a fluke and the chimes returned for another two weeks and then no more. Strange indeed! What gives? Security feature/bug?
 

·
Registered
Joined
·
10,548 Posts
Okay, I see this an old thread, but nothing out there comes as close... I bought a used equinox and the chimes did not work and the radio would skip a beat every three minutes. While performing some repairs that for safety sakes required disconnecting the battery for a few days I noticed that the chimes started working again after reconnecting the battery the radio also returned to normal operation. Cool! Well, it was brief. After about two weeks of normal operation, the chimes quit working again and the radio hiccup returned. I disconnect the battery again to test this as thinking it was a fluke and the chimes returned for another two weeks and then no more. Strange indeed! What gives? Security feature/bug?
Tim - No, this is not a designed feature. Sounds like you either need to get it repaired, or instal la timer that will disconnect the battery every 2 weeks - LOL.
 

·
Registered
Joined
·
2 Posts
Same thing on a 2015

I just came across this thread today. I have a 2015 Chevy Equinox and I turned it on this morning to no sound - no dings, music, phone, turn signals - - nothing. I am not seeing the fuse boxes near the door everyone is talking about. Thoughts???
 

·
Registered
Joined
·
1 Posts
I just came across this thread today. I have a 2015 Chevy Equinox and I turned it on this morning to no sound - no dings, music, phone, turn signals - - nothing. I am not seeing the fuse boxes near the door everyone is talking about. Thoughts???
OK, this is going to sound stupid but my father had the same issue with his 2007 Equinox his chimes and radio would go out from time to time and now like I said this is going to sound stupid we would hit the roof of the car around where the lights are and the radio and chimes would come back. I took the car to a mechanic and told them what we would do to get the radio to work and he looked at me funny (like i was stupid just cause I am a girl and blonde LOL) cause how would that be. Well after him replacing come parts in the steering column do to the fact that sometime the key gets stuck in the ignition and he through parts at it and didn't fix the ignition problem so that will be the next thing I'm going to research. Well back to radio the mechanic never looked in the roof liner of the car after 3 weeks of the mechanic said it was the power amp that was causing the problem well didn't want him to through that part at the car it cost a lot of money if you could find one and is no longer available. I still didn't believe that was going to fix the issue as i was still able to get it to work by hitting the roof by the lights in roof. I started to take down the roof liner by the back hatch door and found in the wire harness a short, once I stated to moved the wires WOW the radio came back on and all the chimes and turn signals clicking again. Radio and chimes have been working ever since, it's been 3 months now and still good. Not sure if this is going to help you but I've been reading just about all the posts and Forums I could find about this issue and the only reason it lead me to the roof panel is one suggested that if you have the roof rack on your equinox sometimes water may have gotten in and caused and issue. hope it helps If not guys I'm not a mechanic but just thought i would put this out there since i haven't been able to find and answer on the fix and yes i can take if your thinking I'm a stupid blonde but it doesn't hurt to give it a try.
 

·
Registered
Joined
·
1 Posts
I would like to look into this for you. Do you have your case number? Please feel free to contact me privately. Thank you in advance.

Tricia, GM Customer Service.
I have the exact same failure in our 2008 Equinox LS and it drives me crazy... i am convinced even if i swapped out the radio with another factory radio the problem would not go away...SOOO **** FRUSTRIATED
 
1 - 12 of 12 Posts
Top