GMC Terrain, Equinox, and SRX Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
This is the first problem we have experienced with our Terrain. First time is has been in significant rain since delivery and when i got out today and tried to lock the doors nothing happened. Checked all doors, everything okay. Had to lock it with the key. Tried my wife's FOB and still nothing. Opened with key and started the vehicle thinking something would reset. Nothing!
I did see one other post like this from sjhalon, but no replies. Has anyone else experienced this with thier FOB's??
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #3 ·
Thank you for your answer. We will be back home on Wednesday, so will call the dealer and make an appointment to get it taken care as well as it's first oil change.
 

·
Registered
Joined
·
27 Posts
fourmoremarine said:
call onstar and make them unlock it each time...
Good one!
Yes, I had this issue once. I just kept trying to unlock and lock, with both Fob's. Then it just started working intermittently after about 20- 30 pushes. Never thought of calling OnStar, doh! After I drove it a time or two, I have never had the issue again.
 

·
Registered
2011 GMC TERRAIN AWD SLT-2 3.0L V6 (LF1) 6T70 Gen 1 Transmission
Joined
·
164 Posts
Try this little trick.

On the drivers door lock where you insert the key there is a tiny metal plate that may stick open slightly
and the computer thinks there's a key inserted and the key fobs will not work.
Just put a drop of wd 40 or other thin lube on the small plate and push your key in and out a few times.
Both of my key fobs stopped working all of a sudden, both had fairly new batteries in them.
After I lubed the little plate both fobs worked fine again and have had no issues since.
Hopefully that is the problem.
I learned that little trick here btw. Big thanks to whoever posted that also.
 
1 - 8 of 8 Posts
Top