GMC Terrain, Equinox, and SRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2011 LTZ and love pretty much everything about it. However, the audio system doesn't always recognize an iPod - ANY iPod. I have a Shuffle, a 5th gen Nano, and an iPod Touch. I get the same results regardless of the media device. When I plug the device in, the system will search for a moment, then display a message that no data was found.

Other times, the system will "index" the iPod and start playing music from the top of the song list (alphabetically).

Other times, the system works just fine, but this is, by far, the rarest of the situations.

I have taken the vehicle to the dealer, thinking that maybe there was a software update needed. They kept it for a day and found nothing wrong with it, even though I was able to show the technician the message about no data found. The dealer said no error messages were being thrown so they can't find anything "wrong" with the system. Then they gave me a print-out of the Supported Devices.

I have even tried a different USB plug.

I'm very frustrated!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
How would erasing help? The problem occurs with three different iPods so the devices are not the problem. The Nano has actually been recently reset. The problem occurred before the reset and is occurring after the reset.

The problem is not with the devices.
 

·
Registered
Joined
·
183 Posts
I had the same problem with my iPod Classic via USB connection. I now use my iPhone 7. Connecting through Bluetooth and setting both the device and the MyLink to "shuffle" works for me. No more endless "indexing" and the steering wheel controls function, too. Hope this helps.
 

·
Registered
Joined
·
2 Posts
On Apple devices and some Bluetooth infotainment systems, improperly unplugging devices will cause corruption in the file that was playing. The next time you go to plug in your device, the infotainment system will no go past "scanning usb", or it will play another song, then lock on the corrupt song. If you can find the file that is corrupt and delete it, you should be fine. If you wiped your device and it still occurs, it is likely the system is not recognizing that device properly OR the song you share with the other devices is corrupt. YRMV.
 
1 - 6 of 6 Posts
Top