GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I purchased the SLT-2 model terrain back in September of 2009, and since day one I have had issues with the iPod mount working with my iPod touch 2nd generation. I have called GM, taken it to the dealership, and talked to radio experts but none of them know how to resolve it. My guess is it just needs a firmware upgrade, but not sure if one exists. If there is one, the GMC techs I talked to didn't seem to know of it. Below are the details, please let me know if anyone else has run into this:

Only when using the iPod Touch 2nd Generation, if I go into "Search" and perform either ALBUM or ARTISTS it will list many blank spaces, and will sometime lists the songs of the last album I listened to as the title of the album, or as the artist, when browsing its respective category. To fix it, I have to go into "Search" then into "Artists" give it about 2 seconds of blank displays (or incorrect displays) then I hit "Back" give it about 5-10 seconds, then go back into the same category I was in, and it will list correctly. However once I select an "Artist" it then lists the albums as the artists, so if I have three albums under that specific artists, it'll list the first three "A" artists I have as the name. Once I click on the incorrectly labeled album, it will display the album correctly and the songs correctly.

My wife has a standard iPod and this issue does not exist. My friend has an iPod Touch 1st generation, I tested it with his, it did not exist. I have contact Apple, updated the firmware and OS, and confirmed that this is not a known issue with the iPod. My other car has a head unit that reads my iPod just fine. I have the standard radio unit (not the advanced NAV unit) in my terrain. Does anyone know anything about this?
 

·
Registered
Joined
·
89 Posts
I have a second gen iPod Touch, which I plug into our Terrain every time I use it. I haven't noticed any such problems. I see you've updated the firmware ect, have you tried just doing a backup/restore? Or try backing up your songs/playlists and then reformatting it? It sounds to me more like corrupted memory on the iPod causing compatibility/read errors with the Terrain.
 

·
Registered
Joined
·
58 Posts
CJ, this issue is discussed somewhere on another thread. The problems seem to be confined to 2nd Gen touches and iphones. I have an iphone 3G and have the same issue. Not sure if the issue lies in the 3.0 software for these devices or in the firmware of the Terrain. Supposedly, Apple is releasing version 4.0 (possibly this week) so I'm hoping that corrects the issue. If not, then hopefully a GM firmware upgrade down the road will do the trick.
 

·
Registered
Joined
·
36 Posts
I have a first gen iPod touch with the 3.0 software. I have also seen this issue. If I hit back and then go back in it *sometimes* fixes the problem.

Definitely annoying, lets hope it gets fixed with the 4.0 or that GM will release a firmware fix.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I appreciate everyones reply. At least I know it's not just me haha. I did try to reformat the iPod entirely, I tried utilizing just MP4 then just MP3 files, I double checked and re-checked ID3 tags to make sure it's not a labling issue on my end, but as I mentioned before my other vehicle has an iPod dock with a central control in the head unit and I've had no issues with that one.

I hope that the latest update indeed does resolve this issue. I have contacted GM and talked to the GMC dealership I purchased the vehicle from, but no support on either side there. I think the issue is just too new and no one really understands the technical side of it yet.

Let me know if anyone finds a resolve, and I will do the same. Thanks again guys.
 

·
Registered
Joined
·
265 Posts
Anyone know if all Ipod Touch 2nd Generation Have issues with playing music thru the system???
 

·
Registered
Joined
·
1,085 Posts
SnowItch said:
I really, really hope that GM does a good job at frequent firmware updates for the infotainment system. Something tells me that they won't (they are a car company, not a computer company), but I am hopeful with the total convergence of the two, that we'll see more frequent updates.
We hope so as well, especially to keep up with connectivity for the new portable media storage devices and of course upgraded Navigation maps (but I think those may come on DVD I remember reading here somewhere).

From what the Service Rep told us, it's a contractor called MASS RADIO upgrading the infotainment systems here in Ontario, Canada anyway.
Apparently they came to the dealership to update our Terrain with their mobile programmer.

RADIO CONTROL ASSEMBLY REPROGRAM BY MASSCOMP'S MOBILE UNIT
THIS RECALL NEEDS TO BE PERFORMED BY MASS RADIO
Link:
http://www.terrainforum.net/index.php?topic=220.msg1582#msg1582
 

·
Registered
Joined
·
89 Posts
nitti48 said:
Anyone know if all Ipod Touch 2nd Generation Have issues with playing music thru the system???
Like I mentioned above, I haven't had a problem with mine.
 

·
Registered
Joined
·
155 Posts
Mobius said:
Like I mentioned above, I haven't had a problem with mine.
I haven't noticed this issue either. the only issue I experienced was the system would randomly disconnect from the iPod but that seems to have been resolved after I reset my iPod (powered off & back on)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
For those of you who are not experiencing the issue, maybe we can use your situation to find out what is causing ours not to work. Do you have the standard radio or the graphical touch screen? Are you utilizing USB connectivity or standard audio in jack? What firmware and which OS is your iPod Touch 2nd Gen operating on? Are you using .MP4 music or .MP3 music on the iPod? Are you using the Apple provided USB cable or an alternative?

Any information would be helpful to try and narrow it down to what the difference is.

tbox302 said:
...the only issue I experienced was the system would randomly disconnect from the iPod but that seems to have been resolved after I reset my iPod (powered off & back on)
I ran into this issue too, but it has happened more then once. Generally powering down the iPod and powering it back on fixes it as you stated, but it does come back later.

TopRowSeat said:
...lets hope it gets fixed with the 4.0 or that GM will release a firmware fix.
Yeah I hope so too. I was trying to get the exact make/model of the radio (without ripping it out of the dash) so I could check the manufacturer. Generally firmware upgrades are simple USB and/or CD/DVD burned images. Put it in, hold a key combination, and let it update. But GM didn't have that information for me, and all the stuff I looked at online didn't have it either.
 

·
Registered
Joined
·
89 Posts
Standard Radio (no navigation).
2nd Gen 16GB iPod Touch
Software Version: 3.1.2 (only recently updated, also worked with the original v2 software)
M4A and MP3's are both being used
Connected via Apple supplied USB cable.

I haven't had any problems at all.
 

·
Registered
Joined
·
155 Posts
Mobius said:
Standard Radio (no navigation).
2nd Gen 16GB iPod Touch
Software Version: 3.1.2 (only recently updated, also worked with the original v2 software)
M4A and MP3's are both being used
Connected via Apple supplied USB cable.

I haven't had any problems at all.
same for me except I have the nav unit, my ipod's an 8GB and I'm currently using a cable that came with a Griffin charging kit though I used an Apple cable with no issues as well
 

·
Registered
Joined
·
58 Posts
I'm just going to use my old iPod Nano for music and leave it connected and hidden in the console at all times. It's only 4 GB, but she'll do the trick and then I can use my iphone as a GPS unit.
 

·
Registered
Joined
·
446 Posts
Here's what I did for music...

I bought a dirt cheap USB flash stick. 8 Gig in size, only cost me about $25. Now I'm not worried about theft, heat, freezing or other issues that might otherwize ruin my MP3 player. I put all the music I wanted on that USB stick, and still have a couple gigs left.

Only thing I dislike is the poor music sorting ability in the GM radio.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Well the only difference from what those of you that are not having an issue is that my iPod touch is a 32gb, and my first iPod touch I tested was a 32gb as well.

I did at one time during troubleshooting put on only about 2gb of music to see if it was a quantity thing, but it still did it. However it may just be the fact that it is a 32gb storage medium.

I will try to find a 16gb somewhere here and get it hooked up to see if that's the only issue. I'd be surprised if it is, but at this point I've tried everything!

Also, thanks earlier for stating .M4A ... not sure why I kept typing .MP4.

Thanks for the information guys. I'm trying to figure this out myself because GM seems to not really know any way to fix it.
 

·
Registered
Joined
·
36 Posts
My iPod touch is 8GB first Gen with the latest OS (3.1.2)

Terrain is SLT2
No NAV or DVD

I *do* have the problem. Took it to the dealer and they had never heard of the issue. Unfortunately they were not able to reproduce. I am pending a second appointment with them where I can (hopefully) demonstrate the problem for them.
 

·
Registered
Joined
·
265 Posts
I too have the 32G Ipod Touch Generation but I do not have my Terrain yet..

How bout a Toshiba Gigabite Ipod?? Wonder if that might work..**** I wish I would get my Terrain..Well atleast I am finding out about the Bugs etc..Thanks
 

·
Registered
Joined
·
446 Posts
SnowItch said:
If I were to use the USB dongles, I would probably follow the advice of a poster on a different forum and actually replace the artist with the playlist. As you stated, the USB sticks are cheap, so this fellow had on 1-2GB stick for every playlist he wanted. A little easier to store than a CD and much less likely to get sratched.
I had that idea too, but didn't do it yet. I saw a 4 pack of 1 gig USB drives for $7 once. Could have grabed a couple of those packs, and used a key tag to label them and kept them in the center console. One stick for each genre or something like that. It is a great idea.

If only we could do movies that way too... :p
 

·
Registered
Joined
·
14 Posts
Discussion Starter #19
SnowItch said:
Anybody else think this might be an Apple issue vice an GMC Issue?
I was thinking that, and I did contact apple tech support. However currently I have used my iPod Touch in my other car which has an after market fold out touch screen head unit, and it works fine there. My friend has a Ford Focus, it works there, and a co worker of mine got the Hyundai Genesis, and it works with his too. It may be an apple issue, but being it works on other head units it's strange if it's GMC specific.

My wife has a standard iPod (120gb) and it works fine on her system, does not glitch at all. So it is specific to the iPod touch.

TopRowSeat said:
My iPod touch is 8GB first Gen with the latest OS (3.1.2)

Terrain is SLT2
No NAV or DVD

I *do* have the problem. Took it to the dealer and they had never heard of the issue. Unfortunately they were not able to reproduce. I am pending a second appointment with them where I can (hopefully) demonstrate the problem for them.
I was able to get the GMC dealership to see my problem, but unfortunately they have no idea what the fix is. The master radio technician there is looking into it, but I haven't heard back from him in a while.

Any other scenarios/information is greatly appreciated guys. Thanks.
 

·
Registered
Joined
·
36 Posts
I have demoed the problem twice for my dealer. They just did the defroster recall and said that maybe that would fix this issue as well since it was a total replace of the head unit.

It didn't solve the problem and now they want me to bring it back in AGAIN so they can continue to not fix it. We all know there is no fix that a local dealer is going to magically provide. This needs to be fixed by firmware either from Apple or GM.

This problem is annoying, but less annoying than not having my car for a day.... again.

(still love the vehicle after 7,500+ miles but growing frustrated with this little glitch)
 
1 - 20 of 28 Posts
Top