GMC Terrain, Equinox, and SRX Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
2012 Equinox - when I connect my Iphone 4s thru USB the infotainment system typically does not recognize it.
The system will "find" the Iphone and then go back to whatever other audio source it had been connected to.
However, if I put the Iphone into the Music app first, it will generally detect.
But it doesn't always have to be the Music app.

Any ideas?
 

·
Registered
Joined
·
2,772 Posts
Have you brought this to the attention of your local dealer? They should be able to assist you further and help to troubleshoot the problem. Please feel free to keep me posted. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
338 Posts
pgranthb said:
2012 Equinox - when I connect my Iphone 4s thru USB the infotainment system typically does not recognize it.
The system will "find" the Iphone and then go back to whatever other audio source it had been connected to.
However, if I put the Iphone into the Music app first, it will generally detect.
But it doesn't always have to be the Music app.

Any ideas?
The fix is supposed to be out in late December. It's an issue with the LG communication module.
 

·
Registered
Joined
·
67 Posts
pgranthb said:
2012 Equinox - when I connect my Iphone 4s thru USB the infotainment system typically does not recognize it.
The system will "find" the Iphone and then go back to whatever other audio source it had been connected to.
However, if I put the Iphone into the Music app first, it will generally detect.
But it doesn't always have to be the Music app.

Any ideas?
I'm having somewhat of the same problem. Plug my 3GS (iOS 4.3.3.) in using Aux or USB and i get nothing..evn in the suggested airplane mode. Nothing happens if I press the AUX button on the radio either. I'm thinking something is up wiht the radio cuz when my dad originally bought the truck, it picked up my iPhone just fine through both inputs. Gonna take it in to have it looked at.
 

·
Registered
Joined
·
8 Posts
Has anyone figured this out yet? I'm having a very similar issue. It will recognize my iphone and play 10 seconds of whatever song is playing then freeze. It will then not recognize anything in the USB slot until the car is turned off for a few minutes and restarted. Then it does the same thing again. Same issue with my iPhone and iPad.

This is really frustrating and I really don't want to deal with the hassle of a warranty repair unless absolutely necessary.
 

·
Registered
Joined
·
2,346 Posts
I have not used the USB but my 5 phone and I pod work fine with the bluetooth. It will pay even Pandora throught the bluetooth.

The only issues I have had is the Pandora and Sticher do not show up on the screen and the incoming calls go to the private setting and has to be sent back to the car. Out going works fine and my music plays fine and even displays the art work fine.

As for my old 3S it worked fine with the latest OS.
 

·
Registered
Joined
·
8 Posts
I should include that I was one of the unlucky saps who purchased a 2012 nox and didn't get the my link with Pandora. I still have to rely on connecting my iPhone. Don't get me started on that. I deleted all my music and re-synced and still have the same issue.
 

·
Registered
Joined
·
2,772 Posts
Mike F said:
Has anyone figured this out yet? I'm having a very similar issue. It will recognize my iphone and play 10 seconds of whatever song is playing then freeze. It will then not recognize anything in the USB slot until the car is turned off for a few minutes and restarted. Then it does the same thing again. Same issue with my iPhone and iPad.

This is really frustrating and I really don't want to deal with the hassle of a warranty repair unless absolutely necessary.
Have you brought this to the attention of your local dealer? Feel free to contact me if you need anything.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
8 Posts
I now have the car playing a USB drive but I'm still having the issue with my iPhone. I know the dealership will tell me the problem is with the phone. Any other suggestions on what to try?
 

·
Registered
Joined
·
32 Posts
Have you tried doing a hard reset on your phone? Hold the home and power buttons down together till the phone shuts off and the apple logo pops up then let go. With the iphones when you hard reset it refreshes the programs just like a computer at home Gives it s fresh start. I had similar issues, mine turned out to be certain ios version would screw things up.
 

·
Registered
Joined
·
8 Posts
Yeah. I've tried that multiple times. I'm really frustrated because it worked fine for 9 months and now it just stopped. After reading other forums, it sounds like it may be an apple issue. I need to do more troubleshooting on my end. Wasn't Apple supposed to "just work."

By the way, that's a joke, I have a degree in computer science. I know better.
 

·
Registered
Joined
·
2,346 Posts
No it is an Apple issue as my I phone 3s with the latest 0S worked fine. Now we just got our I 5 and it has mostly worked but things like Pandora and Sticher do not link. Also there are times the Bluetooth does not want to link. I just shut off the car and phone and it links right away. It has only not linked two times.

Other than the Pandora, Sticher and incoming call issue all of my things work.

Now on the other hand it took Onstar over a month to activate our free Onstar. they kept calling in and did a bunch of changes to make it finally work. They gave us some free time but now that it is out we really had no use for it.

I expect with most all having the same or similar issues that Apple will have a new update to deal with this. The GM system was there and it is up to Apple to match it. Imagine if GM has to chase down every phone system? What a nightmare.
 
1 - 13 of 13 Posts
Top