GMC Terrain, Equinox, and SRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
978 Posts
Discussion Starter #1
From Gm Tech...

Intermittent Service StabiliTrak, Service Traction Control, or Service All Wheel Drive messages may be displayed on the Driver Information Center of some 2010-2011 Equinox and Terrain models. Any combination of the following DTCs also may be set: C0186, C0196, C0710, U0125, U0126, U1826, and U1827.


DTC U0125 (Lost Communication with Multi-Axis Acceleration Sensor Module) may be set along with DTCs C0186 and/or C0196. Another example may be DTC U0126 (Lost Communication with Steering Wheel Angle Sensor Module) set along with DTC C0710. On all-wheel drive models, DTC U1826 (Lost Communication with Multi-Axis Acceleration Sensor Module on Bus B) or U1827 (Lost Communication with Steering Angle Sensor Module on Bus B) may be set in the Rear Differential Control Module.


If a condition is not identified after following the Service Information diagnostics for the set DTCs, check the J307 splice for circuit 2087 (D-GN wire) for corrosion or partially broken wire strands at the splice crimp. (Fig. 17)

Upon inspection the wire may easily break off when moving the harness. (Fig. 18) Complete the wire repair and clear the DTCs.

March 31, 2011 1:35 PM
[/color]
 

Attachments

·
Registered
Joined
·
80 Posts
Hey, I'm not sure I understand everything in there but my 2010 Nox (4cyl, fwd) started having problems with the StabilityTrak ligh going on and off 2 weeks ago. Last week I also noticed the power steering stopped working while the light was on but came back to normal when light was off. (Some times it changed while driving...)

Could it be what is described in there?

I already called the dealer, must go there later this week.
 

·
Registered
Joined
·
2,772 Posts
I am glad to hear that you are planning to work with your local dealership. They are the best resource when it comes to deciding whether your vehicle has these symptoms. Please feel free to keep me updated in regards to the fix either on the thread or via private message. I look forward to hearing from you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
80 Posts
That's exactly what was described here, corrosion. They changed a green wire (like shown on the picture I guess) under the carpet. Took them 30 minutes.

I also asked them to do an oil change, and they told me they would do an inspection too. I said it's fine.

I shouldn't have.

99$CDN for the "inspection" where most things can be done by myself.
(Most of the things are stupid things like "look if the wiper blades are in good condition, look if there are damages to the glasses)

Also, the oil change seemed quite over priced to me. 120$CDN for Castrol Syntec oil. It seems to be about 5 Liters in the 4cyl 2.4L .. Canadian Tire sell the same oil at 45$ for 5 Liters :-[


Anyway, the car runs fine again :thumb:
 
1 - 4 of 4 Posts
Top