GMC Terrain, Equinox, and SRX Forum banner
1 - 1 of 1 Posts

49 Posts
Discussion Starter · #1 ·
I did a search and couldn't find where anyone else has reported this issue, so I thought I'd share. I have an Ipod classic 120 GB and an Equinox with the Navigation system. While I was exercising before work this morning, the battery died on my Ipod.

I got ready for work then plugged the Ipod into the car while I waited for the dog to do her thing. I got in and started the car to leave for work. The system didn't recognize the Ipod (not surprising), but instead of hearing the radio, I just had a clicking sound. I tried changing from XM to FM to a CD - nothing. I tried unplugging the Ipod and unplugging the USB cable from the car - still nothing. Finally, I turned the ignition off and suddenly, the sound returned.

I was curious if anyone else has seen this. It turns out it's not that big of a deal, but was a bit upsetting at first.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.