GMC Terrain, Equinox, and SRX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
For the third time in 2 months, I noticed when I first start the engine I can hear the the injects very load for a few seconds, and for several seconds today, before they quiet down. Then never again all day...anybody else got this problem?
 

·
Registered
Joined
·
5,050 Posts
on the Lamndas 3.6 DI engine- at startup- theres 2 injector pulses or someting like that- then a switchover to 1 pulse.
you can tell the switchover because at some point in the warmup- the RPMs dip when the switch occurs.. could this be it?

Clearly seen on plotted data via the OBD port.
note the spike at -68 seconds....


 

·
Registered
Joined
·
5,050 Posts
The fuel pulse dampener may have an audible clicking sound when the engine is idling.


 

·
Registered
Joined
·
67 Posts
Discussion Starter #4
This noise is so loud, it sounds like rods in an engine knocking...
 

·
Registered
Joined
·
67 Posts
Discussion Starter #5
The question is...is the injector getting ready to crap out,, because they never make a loud noise again during the day...
 

·
Registered
Joined
·
67 Posts
Discussion Starter #6
ok...I think I figured out what's going on....when you turn the key on half way the fuel pump kicks on to load the injectors, some times the pump doesn't load the injectors fast enough, which causes the injectors to rattle before being filled with gas...
 

·
Registered
Joined
·
441 Posts
you sure its an ijector? usually ticking at startup is caused by a lifter sticking....sometimes can be fixed by switching brand of motor oils...my old 3.1 beretta would have it if i ran anything other then valvoline....guess the additives helped out...
 

·
Registered
Joined
·
67 Posts
Discussion Starter #8
I don't think so....the noise is a lot louder then a sticking lifter...
 
1 - 8 of 8 Posts
Top