GMC Terrain, Equinox, and SRX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2011 Luxury Edition SRX that I purchased in January. Is anyone else having a problem regulating the heat? Sometimes no matter what I do it only blows cool, not cold air. I've tried various settings in the HVAC menu but nothing seems to work. I also hear a clicking sound coming from under the dash but I don't know if the two are related.

Thanks.
 

·
Registered
Joined
·
139 Posts
Are you talking about the A/C system or Heat?

Not sure if this helps and don't take it wrong but if you are talking about the A/C which it seems you are have you turned on the actual A/C system instead of it just blowing cold air. My Terrain has a button to turn A/C on or off so if the system isn't actually activated it will just blow cool air. If thats not the problem just bring it into the dealer and explain the problem...they should be happy to fix it under warranty. Hope this helps.
 

·
Registered
Joined
·
136 Posts
BlackSRX said:
I have a 2011 Luxury Edition SRX that I purchased in January. Is anyone else having a problem regulating the heat? Sometimes no matter what I do it only blows cool, not cold air. I've tried various settings in the HVAC menu but nothing seems to work. I also hear a clicking sound coming from under the dash but I don't know if the two are related.

Thanks.
Our SRX's have an interesting feature called "auto anti-Fog" (or close to that!) It simply turns on the A/C unit (the LED will NOT illuminate as a clue to you that it is ON) and dehumidifies the air to prevent window, interior fogging. It can throw off your heat a bit!

Go into the CONFIG menu and under "Air quality/fog control" (or similar words) un-check that option!

Problem should disappear. Factory default is checked ON.

MM
 
1 - 4 of 4 Posts
Top