GMC Terrain, Equinox, and SRX Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
537 Posts
Discussion Starter #1
All the sudden I cant get anywhere close to or above 15mpg its like in the 14 range, jumped down from 18-20mpg city to now like less than 14 mpg no other symptoms no check engine... idle is kind of loud seems like the vvt is acting up or something. I did floor it through a red light maybe its sticking idk... Suggestions?
 

·
Registered
Joined
·
537 Posts
Discussion Starter #4
Oil is good looking at the data my short term fuel trim and long term fuel trim are wayyyy off idk probably vacuum leak or bad sensor I'm at 14mpg city
 

·
Registered
Joined
·
231 Posts
It was a stuck valve used a bunch of Lucas oil upper cylinder lube within 10 minutes the gas mileage came back and idle is significantly quieter. I'm up to 20mpg city.
Which motor?

2014 Terrain SLE-2 /Silver Sky Metallic / 3.6 L V6 / AWD / Pioneer Stereo / 85,600 miles as of March 2021
 

·
Registered
Joined
·
537 Posts
Discussion Starter #8 (Edited)
the 2.4, I floored it and everything was good but my mpg's just started dropping and dropping I was like HUH? I'm thinking this is why these motors crack exhaust manifolds so often.
 

·
Registered
Joined
·
935 Posts
2.4 crack manifolds because that heavy cat is hanging right off it along with the front half of the exhaust system.
Manifolds are a issue in any 2.4 in any model they are in. Common in Malibu's for example.
 

·
Registered
Joined
·
537 Posts
Discussion Starter #10
Yea good point I used to think they crack because of bad trans mounts / motor mounts... Someone should make a bracket kit or something.
 

·
Registered
2011 GMC TERRAIN SLT-2 3.0L V6 (LF1)
Joined
·
44 Posts
Chris, that is exactly what I was thinking of.
Since I have the 3.0l im not too familiar with the 2.4l issue, I just learn from
reading what others are saying. Does gm cover cracked manifolds under a warranty
or is it on the owners own dime to fix the problem?
 

·
Registered
Joined
·
537 Posts
Discussion Starter #12 (Edited)
They do actually cover it I'm pretty sure up to 100k mine had broken studs on the cat and a cracked manifold... It was covered. Then that manifold cracked... So 2x the second one I put on.
 

·
Registered
Joined
·
11 Posts
All the sudden I cant get anywhere close to or above 15mpg its like in the 14 range, jumped down from 18-20mpg city to now like less than 14 mpg no other symptoms no check engine... idle is kind of loud seems like the vvt is acting up or something. I did floor it through a red light maybe its sticking idk... Suggestions?
Check the operation off the 02 sensors.
 
1 - 14 of 14 Posts
Top