GMC Terrain, Equinox, and SRX Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I recently had to replace the drivers side hub on my wifes 2005 equinox!! After getting it done i noticed that the actual wire harnesses & plugs that connect to the ABS sensor was messed up!! Does anyone know what the part number of the wire is? Every dealership I have called keeps trying to tell me that i need the harness that attaches to the speed sensor but i need the wire harness that connects to that and runs behind the plastic cover into another female connection!! The wire is 3 feet long and has male connections on both ends!!

I have put pictures on here to help!!

Thanks in advance!!
Mason
 

Attachments

·
Registered
Joined
·
338 Posts
Why can't the harness be repaired? I have seen it done many times.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
i would need new connectors since i do not know how to get the wires out of the existing connectors!! I would like to buy a new part so i know that it works and nothing is wrong with it since it is part of the ABS system!!
 

·
Registered
Joined
·
2,271 Posts
mbrown said:
i would need new connectors since i do not know how to get the wires out of the existing connectors!! I would like to buy a new part so i know that it works and nothing is wrong with it since it is part of the ABS system!!
why do you need the wires to come out? get a good can of contact cleaner and spray the **** out of the replacement harness the wires shouldn't be coroded unless the "seals" in the connectors are messed up
You can run a test on each wire before you put it on your vehicle to see if it flows... It might not be your harness..
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
the wires were messed up when the axle boot blew out and sprayed grease all over the place! I would rewire it but don't know how to get the wire size or how to get the wire out of the existing connection!
 

Attachments

·
Registered
Joined
·
2,271 Posts
mbrown said:
What would the part number that i need for either the whole harness or the connections?
I'm sure you need a special tool"picks" to get the wires out of the connectors then you would have to be able to put new terminals on the replacement wire before you inserted them back into the conectors Wouldn't it just be easy to go to the junk yard get underneath a 05 they have unplug the harnes buy it take it home spray the ends with contact cleaner put in some dialetic grease, and plug it back into your vehicle?
 

·
Registered
Joined
·
157 Posts
Which part do you need - here is the illustration out of the parts book.
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
by looking at that picture i think that i need part number 9! but what it looks like that part has a connection coming off of it in the middle! The part i need is just one wire that is three ft long and has only 2 male connections on it! It might also be part number 5 from your diagram!

Thanks
 

·
Registered
Joined
·
157 Posts
It took some searching in both the service manual and the parts book to find the right illustration showing the part.

I believe this is what you want - short harness from the ABS sensor pigtail to the main body ABS wiring harness (behind the fenderwell liner)

I added the part number to the drawing
 

Attachments

1 - 12 of 12 Posts
Top