GMC Terrain, Equinox, and SRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Having an problem with heated driver seat in my 2010 Equinox (LTZ w/leather). I am just talking about operation when the vehicle is running normally - not remote-start operation. Sometimes it works and sometimes not. When it is not working, I hear a click in instrument panel area and it shuts off about 5-10 sec after button depressed. I have had the seat heating element replaced by the dealer. It worked for a short while and then went back to intermittent operation. Whenever I have it checked by the dealer, it works. Then the next day it does not. Sometimes it will stay on for a minute or two and then shut off. Can anyone shed any light on a fix??

Thank You and Best Regards
 

·
Registered
Joined
·
2,772 Posts
I would be happy to look into this for you. In order to do so, I will need some more specific information from you. If you could please send me your full name, address, phone number, the VIN for the vehicle, and current mileage via private message, I will be able to take further steps. Thank you again and I look forward to hearing from you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
56 Posts
I had an issue with the 8-way power seat -- the rear elevation motor wasn't working.

I did a little poking around, and noted the huge, clunky yellow connector under the driver's seat. I pushed both halves tighter together, and that did the trick.

You might try the same if you can find the heater connector.

I wonder why the designers left that connector just flopping about on the carpet like that...?
 

·
Registered
Joined
·
2,828 Posts
I just experienced this also this past week. Seats would not heat up when turned on every time.
Dealer ran diagnostics and it turns out my one power switch on my drivers seat is faulty.
New one is ordered so we'll see shortly if it proves good.

My dealer has replaced a few seat modules already because of this intermittent seat heaters not working, the power seats and heater controls all run through this same module, so one issue could affect the other.
 

·
Registered
Joined
·
412 Posts
The wife was having an issue with the passenger seat heater recently. It was warming on the lower part but nothing on the back (in the max heat position). When she turned it down to the middle positon both lower and back would work. Later in the trip it seemed to be working ok but it's on the list for the next trip to the Service Dept.
 
1 - 5 of 5 Posts
Top