GMC Terrain, Equinox, and SRX Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
337 Posts
See attached.
 

Attachments

·
Registered
Joined
·
23 Posts
I have a 2012 Equinox. Just changed out my headlight assembly and need to adjust my headlights aswell. Does anyone have a link to a video that they used themselves to be accurate? I saw the document posted and would prob be a little more clearer to me on video. Any help would be appreciated.
 

·
Registered
Joined
·
2,947 Posts
Calidoso said:
I have a 2012 Equinox. Just changed out my headlight assembly and need to adjust my headlights aswell. Does anyone have a link to a video that they used themselves to be accurate? I saw the document posted and would prob be a little more clearer to me on video. Any help would be appreciated.
Adjusting headlights is only covered in the GM Service Manual not the Owners Manual as previously posted.
 

·
Registered
Joined
·
2,947 Posts
Any idea of what tool and size is needed for adjustment?
My 2014 Equinox LTZ with projector lights can be adjusted with a Phillips screwdriver.
Only vertical is adjustable, horizontal adjustment does not exist.
Look down on this page for "Recommend Reading", there are several threads on this.
 

·
Registered
Joined
·
19 Posts
I don't see a Philips screw adjustment, all I see is a 10mm screw. I am stuck out visiting my daughter with minimal tools and she travels around with some cargo, the headlamps aren't shining on the roadway. I only have one more day to get this done too.:unsure:

Its a 2015.

Found this video. 10mm bolt.
 

·
Registered
Joined
·
19 Posts
We got the headlamp adjusted, looks ok to me now. As we were leaving for a parking lot she got a CEL. P0420 and P0430. I called Onstar for a diagnostic and she told me it was a P0420 and a P0430. I checked the air filter, looks OK. The follow up Email from Onstar also said B01, bulb outage indicator, checked all the outside lamps, all good. More specific was U0151 and U0155; any ideas? 2015 Nox 6 cylinder.
 

·
Registered
2010 chevy equinox 2.4
Joined
·
950 Posts
Did the battery happen to get low during the adjustment? Idk if it is the original from 2015 but when the battery gets low the car can throw random codes. Once p0420 or 0430 are set they can go away on there own but the pcm decides when it's clear..Catylist efficiency only is the problem.. It might just shut off after 5 drive cycles or a long highway drive. The computer will instantly set those codes if it runs rich even for a minute... If those 2 are your only engine codes I would not REALLY be worried... The other codes are random I'm thinking they came up at some point but are not perminant codes they just came up on the code history through onstar. If you do have any actual problem with like fuel psi , clogged air filter ECT . It would be a separate code. P0420 is probably the most common code because if the voltage of the downstream 02 sensors are above .45v for an extended time when the car is in closed loop and hot. Idk if you use top tier gas? Maybe some carbon buildup was burning off or something? P0420/ 430 will set a check engine light it would help to know though if the code is listed as current or permanent... Current would just mean it only happened for a few seconds and should clear...perminant would mean you may actually have a problem. A good scanner can also give you past data or let you know if any codes are about to set/ pending.
 

·
Registered
Joined
·
19 Posts
I cleared the codes with my Actron scanner which I left in her Nox. No codes on our ride of 10 Min highway. I doubt the gas she uses is Top Tier so I will get on her to start using the good stuff and get a bottle of Techtron in there today.
 

·
Registered
Joined
·
2,947 Posts
I cleared the codes with my Actron scanner which I left in her Nox. No codes on our ride of 10 Min highway. I doubt the gas she uses is Top Tier so I will get on her to start using the good stuff and get a bottle of Techtron in there today.
UO151 code is a seatbelt or possible, but rarely, an airbag communication lost code.
UO155 code is an instrument cluster communication code.

I would clear all codes and drive it.
 

·
Registered
Joined
·
19 Posts
Did the battery happen to get low during the adjustment? Idk if it is the original from 2015 but when the battery gets low the car can throw random codes. Once p0420 or 0430 are set they can go away on there own but the pcm decides when it's clear..Catylist efficiency only is the problem.. It might just shut off after 5 drive cycles or a long highway drive. The computer will instantly set those codes if it runs rich even for a minute... If those 2 are your only engine codes I would not REALLY be worried... The other codes are random I'm thinking they came up at some point but are not perminant codes they just came up on the code history through onstar. If you do have any actual problem with like fuel psi , clogged air filter ECT . It would be a separate code. P0420 is probably the most common code because if the voltage of the downstream 02 sensors are above .45v for an extended time when the car is in closed loop and hot. Idk if you use top tier gas? Maybe some carbon buildup was burning off or something? P0420/ 430 will set a check engine light it would help to know though if the code is listed as current or permanent... Current would just mean it only happened for a few seconds and should clear...perminant would mean you may actually have a problem. A good scanner can also give you past data or let you know if any codes are about to set/ pending.
No I don't think the battery went low, I believe it is pretty new, changed before she drove out to the Rockies. I will check and make sure it is only 1 year 2 months old. I know she keeps a phone jack wire in the center console, sometimes I see the light on. Does the center console light time out after locking?
 

·
Registered
Joined
·
2,947 Posts
I know she keeps a phone jack wire in the center console, sometimes I see the light on. Does the center console light time out after locking?
The orange wire that powers the center console light comes directly from the BCM.
I have noticed mine stays on for a while, more than 10 minutes, but will eventually shut off.
The wiring diagram does not show it going through the RAP relay.
It is circuit #6815
 
1 - 13 of 13 Posts
Top