GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 54 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
well have this nasty rattle as it sounded like the bottom end of my motor was letting go. Looks like there has been some issues with the timing chain on these Equinoxs. Anyone else going through this?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
Yep the faint sound in the background is the same.It actually is really heard when you have the brake on with some acceleration at the same time.
 

·
Registered
Joined
·
1,085 Posts
baddabing said:
Yep the faint sound in the background is the same.It actually is really heard when you have the brake on with some acceleration at the same time.
So it's not the prevalent "tat-tat-tat-tat" of the injectors (which is VERY LOUD compared to the V6), but what sounds like a metal bucket with a few loose bolts being shaken up?
 

·
Registered
Joined
·
1,082 Posts
Yup. That is timing chain all the way. Thats why its so important to use a good oil in the ecotec.
 

·
Registered
Joined
·
277 Posts
Can we get a little more detail on this?? We talking the I4 or the V6 here? Timing chain issues on a virtually new vehicle is not a good thing....ask some 80's era Jag owners about it....like me.
 

·
Registered
Joined
·
115 Posts
oh sh*t. well this is very alarming. I wonder why it is making such a racket and still running, instead of just breaking. So I would bet against timing chain as the problem. I didn't bother to check whether the 2.4l is an interference engine because I was confident about having a timing chain (instead of belt). In any case, it sucks having pieces of shrapnel flying around in the engine.

baddabing...I hope you get a new engine. Has your car been showing other symptoms besides the noise?

I will be pissed if we have timing chain issues, then I will run this thing into the ground to break it before my 5 yr power train warranty is up. But hopefully we don't.
 

·
Registered
Joined
·
1,082 Posts
Not to freak anybody out but the car in the video is a Cobalt which has a different Ecotec engine in it.

Very few Ecotecs have a timing chain problem. In 02 when it was new there was failures on those engines because they used the wrong size oil squirter and they would fail around 150-160k miles.
 

·
Registered
Joined
·
315 Posts
mntnpeak said:
Uhhh.... this is not an Equinox
The OP's is an equinox or maybe Terrain

The video is a 2.0 SIDI Ecotec w/ VVT as well...It was posted as reference, because so many people on this site think they have issues with there 2.4L I perfer to show what each actually sounds like......cause after this type of post, I expect others to think their normal DI/VVT engine sounds are timing chain issues instead
 

·
Registered
Joined
·
115 Posts
baddabing...any update? Interested to know what the issue was...
 

·
Registered
Joined
·
115 Posts
bump...sorry to be such a pest just the suspense is killing me!
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #13 ·
Sorry guys been working nights and sleep is killing me...Anyways I brought the vehicle in on Thursday thinking it would have been done but got a call that the advisor didnt order a valve cover gasket and it wont be here till this wednesday...I am not too happy about this and am thinking of trading it in as this is a pretty intense fix I think for a new vehicle..but we will see. I will keep you posted next week... They have also told me they have had one fix so far and it is not common.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #15 ·
Well it went in again and was told they finally have all the parts. I will update this when I get it back and let you know what the service report says.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #16 ·
So the fix they say was the timing belt tensioner it is quieter but I still hear the noise so not sure what else to do.
 

·
Registered
Joined
·
1,082 Posts
Is it louder than other 2.4 equipped vehicles on the dealers lot?

Also, no chance for a video?
 

·
Registered
Joined
·
115 Posts
baddabing said:
So the fix they say was the timing belt tensioner it is quieter but I still hear the noise so not sure what else to do.
Dude, this is f*cked up. the NOX does not have a timing belt, or a timing belt tensioner. You need to tell your mechanic that he is a dumb a$$hole, and a liar, and then go somewhere else.
 

·
Registered
Joined
·
315 Posts
dm2010nox said:
Dude, this is f*cked up. the NOX does not have a timing belt, or a timing belt tensioner. You need to tell your mechanic that he is a dumb a$$hole, and a liar, and then go somewhere else.
It does have a timing chain tensioner, and I'm sure that is what he was talking about.
 

·
Registered
Joined
·
1,082 Posts
dm2010nox said:
Dude, this is f*cked up. the NOX does not have a timing belt, or a timing belt tensioner. You need to tell your mechanic that he is a dumb a$$hole, and a liar, and then go somewhere else.
Yes, it does have a tensioner. Most drivers interchange belt and chain so its very easy that the OP just said belt instead of chain.
 
1 - 20 of 54 Posts
Top