GMC Terrain, Equinox, and SRX Forum banner

81 - 100 of 127 Posts

·
Registered
Joined
·
10,525 Posts
vineyard311 said:
The dealership told me they were replacing the entire head unit, that included the Nav and HVAC controls.
No wonder the systems cost so much on a new car. They have to have a pot of money in reserve to cover repair co$t$.
 

·
Registered
Joined
·
16 Posts
So I've had a few new electrical problems with my replacement NAV....

-Gear selection lights stay on bright during nighttime periodically
-Hot and cold temperature settings were inverted. I kept turning up the temperature setting and the air got colder and colder..
-NAV Screen/HVAC controls momentarily shutoff when the ABS kicks on.
-Onstar stopped working for a bit

I won't be buying another GM navigation unit in my next vehicle.
 

·
Registered
Joined
·
10,525 Posts
vineyard311 said:
So I've had a few new electrical problems with my replacement NAV....

-Gear selection lights stay on bright during nighttime periodically
-Hot and cold temperature settings were inverted. I kept turning up the temperature setting and the air got colder and colder..
-NAV/HVAC controls momentarily shutoff when the ABS kicks on.
-Onstar stopped working for a bit

I won't be buying another GM navigation unit in my next vehicle.
Stinks when a dealer "fixes" one thing, and breaks three more. :thumbdown:
 

·
Registered
Joined
·
7 Posts
Update: the dealership called after having it a few days. They said they looked at it and that the navigation system is working fine. None of the problems I reported to them were happening. My husband picks it up and as soon as he turns it on the agree page pops up and it is defaulting back to Washington DC. So he calls GM directly from dealership parking lot. GM says they will work with dealership to get this fixed. A fe days go by with GM and dealership playing phone tag. Finally a GM rep called my husband says w need an SD chip, but it is on back order. Ok. More weeks go by. We finally receive a package from GM. It is a disk with the bulletin on it. We follow instructions that came with the disk. We tried it two times, the bulletin did not correct the issues. And I thought we were getting an SD chip not a disk. Now 3 months and still not resolved. Plus I am now experiencing more engine troubles.
 

·
Registered
Joined
·
48 Posts
Bottom line, there does not appear to be a fix for this problem. I have had this problem look at three different times by, in my mind a top notch Chevy dealer that I have been dealing with since 1973. If they are going to replace the system there must be no fix with the update.
 

·
Registered
Joined
·
1,537 Posts
Same problems. I brought it in about a year or 2 ago. Fixed. Now It's doing it again. With the CD player when you come back to car the CD player starts with Track 1 even though it may have been on 6 or 7. The real problem is it it was on track 50 or 100 (mp3) and you didn't remember the number - you have to satart all over again. I bet there are a lot of songs I've never heard yet. Now it's turning itself off when you leave the car and you have to turn it on every time you enter the car and still have to find your last audio track.

Now that it's out of warantee, can I still get it fixed since it's an ongoing problem and have had it fixed once?

Other then my oil problem this is really ticking me off.

I also start all my trips in Washington, DC

Give me an old fashioned push button radio any day.

Is there ANY car that doesn't have a infotainment system problem???
 

·
Registered
Joined
·
10,525 Posts
GARYD said:
Is there ANY car that doesn't have a infotainment system problem???
Other than losing one day in the calendar's date a couple of times a year, I do not have any problems with my '10 Pioneer non-Nav Infotainment system.
 

·
Registered
Joined
·
48 Posts
Garyd, what did they replace it with?
 

·
Registered
Joined
·
1,537 Posts
They didn't replace it. According to them all it needed was an downloaded update....and as others have said, it was fine for a couple months and then turned back into a complete PITA.
Now that the warrantee is over I'm wondering if it will be repaired again under the previous warrantee or will I have to pay this time.
 

·
Registered
Joined
·
1 Posts
My fiance' and I just latched on to a beautiful 2010 Terrain SLT2 with navigation system.

The radio resets to WASHINGTON DC on the navigator and the time is always off 5 hours or so, among other things.

Having read about a software update online, we took in in for service and paid the dealer to flash the firmware or whatever process they do. This did not fix the problem.

?? Has anyone on this thread/forum with these issues actually ever got them completely resolved? If so, how? Is there a way to check the radio ourselves and see what software level it has, and if it is the latest?

Thanks..
 

·
Registered
Joined
·
1,537 Posts
Mine does the Washington DC crap also, but I can live with that. I can't live with the CD player starting with track 1 every single time I restart the car. I have a CD with 70 tracks on it. If I don't remember to see what was the last track played, I can't go back and start where I left off so it starts from 1 again. I bet I have 50 songs I've never heard yet. It's maddening. Last time I took it in they said "Worked fine for us" %$#@%$ :facepalm:
 

·
Registered
Joined
·
50 Posts
poppabusa said:
I think you will find after reading a bit more on this forum that the 2010 Terrain is a POS.

I stand by this statement. I don't know of one 2010 2.4L Terrain owner that has not had navigation or engine oil consumption problems - both very expensive repairs.
 

·
Registered
Joined
·
1,537 Posts
I am a slow learner. I have to replace the CD in my player because - I'M SICK TO DEATH OF THAT FIRST SONG. Which keeps playing everytime I enter the car. Doesn't matter what CD or what track is playing when I leave the car - it always starts with the first track upon re-entering. Of course the dealer says there's nothing wrong....maybe HE likes that song. :)
 

·
Registered
Joined
·
48 Posts
I own a 2011 equinox LTZ with 36000 miles. I have the nav system. I had at least 3 upgrades that did not resolve the problems. The unit was replaced with a refurbished one. These units have a power supply problem that affects the memory. At least they think they know what the problem is so they can repair it. And an update is not the answer. So far no problems. If any problems arise I will up date.
 

·
Registered
Joined
·
1,537 Posts
Now, not only does the CD play the first track when re starting the Terraine, but the clock keeps going back to the previous hour when I re-enter the car......THIS IS MADDENING!!!!!! :banghead: :banghead:
 

·
Registered
Joined
·
10,525 Posts
my06gto said:
I wish a fellow forum member was an electrical engineer that could figure out what is wrong and show us a way to fix it.
If you'd like, drop your car off at my house, and I'd be happy to take a look, but if the designers can't figure it out, not sure that I'd have much luck. :confused:
 

·
Registered
Joined
·
35 Posts
Rit said:
If you'd like, drop your car off at my house, and I'd be happy to take a look, but if the designers can't figure it out, not sure that I'd have much luck. :confused:

I just figure that the designers aren't at all looking into this issue. They've moved on to Chevy mylink with us oldtech adopters left out in the cold.

I have an 06 gto and the forum members on ls1gto were amazing. Any issue we had was figured out and resolved. There was even a guy form AZ that made a kit to add AUX in for the factory stereo. It was a site of enthusiasts and tinkerers. I wish equinox and terrain owners possessed the same passion and skills that's all.
 

·
Registered
Joined
·
10,525 Posts
my06gto said:
It was a site of enthusiasts and tinkerers. I wish equinox and terrain owners possessed the same passion and skills that's all.
We're pretty good at putting gas in our cars ! LOL
 
81 - 100 of 127 Posts
Top