GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 127 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
:help:

So this is my first time posting, and I'm new to this forum, so bear with me. I'm hoping someone can help me with this new glitch I'm experiencing!

I own a 2010 GMC Terrain SLT-2 & love almost every bit of it. I've owned it since April 2010, but within the past 2 months I've been encountering glitches that involve the navigation and for the life of me I can't figure out how to fix it.

The following are the issues I'm experiencing (which I have never experienced prior to the last 2 months):

First off, I have to hit AGREE every time I press the nav button after turning my car on. Originally, I would have to agree appx once a month or so which was no problem at all, but every time is a bit too much.

When I click destination, the state defaults to Washington, DC. I change it to california, but after I turn the car off, it resets back to DC.

I can be playing my ipod via USB, but after I turn the car off and then back on, it automatically tunes to my radio. It used to, without fail turn on to AM EVERY TIME I would turn my car on, but now FM sometimes too. Originally, it would continue playing my ipod from the point of the song when the car turned off.

Lastly, after hitting agree and viewing my nav, it takes about 2-3 minutes to calibrate itself to figure out where I am. This was NEVER an issue during the first year of the car. Now when I turn it on, it pretty much loses it's sense of direction. For instance, I'll travel east, and the navigation will move but go North, so it looks like I'm off-roading. It usually calibrates itself within a couples minutes.

Those are the main issues I'm experiencing with my nav. I don't know if I have a glitchy unit, or if some other people have the same problem. Regardless, I'm hoping someone can reach out who might be able to help.

Thank You!
 

·
Registered
Joined
·
978 Posts
Take your vehicle to your dealer and ask them to do this bulletin:

#PI0285: Inconsistent Rear Back-Up Camera Operation, Bluetooth Delay, Intermittent Audio Concerns, Blank DVD Display, Various Additional Navigation Radio/Clock Concerns - (Nov 4, 2010)


Subject: Inconsistent Rear Back-Up Camera Operation, Bluetooth Delay, Intermittent Audio Concerns, Blank DVD Display and Various Additional Navigation Radio/Clock Concerns


Models:
2010-2011 Buick LaCrosse
2011 Buick Regal
2010-2011 Cadillac SRX
2010-2011 Chevrolet Equinox
2011 Chevrolet Cruze
2010-2011 GMC Terrain

All with Navigation Radio RPO UYS
Attention: This bulletin addresses many customer concerns with one convenient software update. Additional user enhancements are part of this update and are outlined below.
--------------------------------------------------------------------------------

Condition/Concern
Customers may comment on any of the following concerns:

• Intermittent rear camera image not displayed, but the guidelines and "Check surroundings for safety" text is displayed.

• Rear Camera Always ON.

• Rear Camera Fuzzy Display - Wavy lines on rear camera and MAP image. Also MAP and Rear camera image together on screen HMI at same time.

• Buick off-screen display does not match IPC color.

• Choppy audio playback from the hard disc drive for a few seconds, one to two minutes after start up.

• Previous route shown on start up, no guidance provided.

• "Unknown Mode" displayed when using an iPod.

• Rear park assist icons will be displayed when audible tone is heard (2010 SRX and 2010 late build LaCrosse only).

• "UPA Symbols Unavailable" message displayed immediately following a reverse to drive transition.

• The clock may reset to 12:00.

• The clock is inaccurate.

• Unable to adjust the hour and/or minutes on the clock.

• Location resets to Washington DC every ignition cycle (corrected once GPS signal is received).

• Last audio source is lost after ignition cycle-Defaults back to FM preset (For example-user was listening to CD. Turned off vehicle and waited 10 minutes. Turned on vehicle and now FM playing).

• "I Agree" screen is displayed every ignition cycle.

• Addresses that have been entered into the radio can be deleted temporarily from the list. After the vehicle sits for about 10 minutes, the addresses have reappeared in the radio.

• Navigation guidance pauses during active route guidance. XM Traffic and Weather data are unavailable during this occurrence.

• DC charger interference causing no audio condition on start up.

• UPA symbol menu selection displayed for vehicles built without RPO UD7 (2010 LaCrosse only).

• Difficultly making appropriate menu selections to return to previous screen. (A Back button is added to many screens, and the CONFIG menu selections are displayed in list form with this software update).

• Blank display with DVD video as active source during start up.

• Audio source reverts to USB/iPod during start up.

• Address displayed on the navigation display does not match the address that was given to the OnStar advisor.

• No extended XM Weather data displayed if the user selected date is advanced beyond the current date.

• Radio presets are erased after programming any module on the vehicle.

• XM traffic prompt may not contain the ‘s’ for miles prompting.

• Different distances displayed on the IPC and navigation display when in metric mode.

• Rear seat audio or rear seat entertainment system does not turn off when the radio is turned off.

• Scanning XM displayed on every start up.

• 1-2 second hesitation when using voice recognition for Bluetooth phone functions.

• HVAC pop-up does not expire.

• XM list resets to the top without user action - occurs when user turns off an XM category.

• Display goes up without user action in key off and door closed. (SRX specific concern)

Software interaction with other vehicle systems may intermittently cause any of the above conditions.


[/color]
 

·
Registered
Joined
·
2 Posts
Just dropped off my 2010 Terrain for the third time to address the same issues you are experiencing and more. In fact many listed in MOCHANOX's post I've experienced. The bulletin worked for a day. Take it to your dealer and demand the system be replaced. That's what will be happening to mine tomorrow. Hopefully that will solve the issue. Don't let the dealer talk you into leaving the car for hours while they fart around with it.
 

·
Registered
Joined
·
2,772 Posts
vallew said:
Just dropped off my 2010 Terrain for the third time to address the same issues you are experiencing and more. In fact many listed in MOCHANOX's post I've experienced. The bulletin worked for a day. Take it to your dealer and demand the system be replaced. That's what will be happening to mine tomorrow. Hopefully that will solve the issue. Don't let the dealer talk you into leaving the car for hours while they fart around with it.
I am glad to hear that you are working with the dealer regarding this concern. Please contact me and let me know how it works out at this visit. Thank you in advance.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
So I have an update.

I took my car to the dealership and told them all the problems with the Nav. I also showed them the info below (thanks Mochanox). They applied the update on Friday. Everything worked perfect.

Fast forward to today (Saturday, 1 day later). I'm getting in my car and I have to hit agree! It popped up right when the car was turned on. I thought maybe it's a fluke. I click agree and then hit destination. IT RESET BACK TO WASHINGTON DC!!!! You've got to be kidding me.

I don't know what to do! Whatever they did, the music and ipod situation is now fixed, but I still have to hit agree and my default state changed!

Do I have a bad navigation unit, should I demand it be replaced like Vallew said. He was right saying it will only work for a day...

Please advise!
 

·
Registered
Joined
·
265 Posts
I am also having many of these same issues...The Washington DC thing..When I turn the radio off after using when I start it back up its on scanning usb stick or not on the channel I originally had it on...It took me 3 times to instill in the Managers head that there was sum kinda fix..a Bulletin...He seems to think it all started when my car was towed to dealer because the car would not start(Bad Battery) which he finally found in his puter notes..I am taking it in tommorrow to see if they can do anything..Bad part is you cannot always recreate the situations that you see..Sometimes it does it..sometimes it does not..but the Washington DC thing always happens..I go to Address entry and it always say Washington DC..Stwitch it to New York and its Washington DC for next Address Entry..I am Retired but hate screwing around for hrs especially if they cannot fix..Unit was over $2000..if not fixable order me a new one..We will have to see what transpires.....One thing has always been it seems..They are fast to take your money but oh so slow to remedy the situation..... Disappointed 2010 Terrain Owner :shrug:
 

·
Registered
Joined
·
2,772 Posts
Dear nitti48,

We can understand the frustration that you are experiencing with your situation. Please, provide us with any updates that you would like to share about your visit to the dealership. Please, keep in mind that taking it to the dealership is the first step in any of our processes in working towards a resolution.

Michelle, GMC Customer Service (assisting Tricia)
 

·
Registered
Joined
·
265 Posts
Well I took my 2010 Terrain into my GMC Dealer yesterday and it took almost 3 hrs to download the software upgrade mentioned here..They knew about it as about 6 other owners had the same problem..Washington DC problem..memory problems in Pioneer stereo etc..I can say Mission accomplished..Everything working tip top now..So glad I belong to this Forum..Thanks for everybodys imput and information..So far now a satisfied 2010 Terrain owner... ;)
 

·
Registered
Joined
·
89 Posts
there are a few other threads about this issue. makes interesting reading.
I have the update done twice, the first one did not take due to a glitch. Everything worked for awhile, then symptoms started coming back. When I finally lost bluetooth, then I took it back to the dealer. I talked to the service manager and tech guy, who looks exactly like you would think that a "tech guy" should look like: young, scruffy beard, I felt like he was cast in a movie.
They said that the radio/nav is now a tagged part and they need to keep the car to get on the horn with Detroit to go over check points, it takes hours. I did not leave it, said I will be back the next day, then bluetooth started working, so I still have it, but Wash DC and Agree Screen is there every time still. I would bet that GM is not happy with Pioneer/Alpine, these units were expensive and their problems are why the GM and Ford have slipped in cust satisfaction. :-\
 

·
Registered
Joined
·
265 Posts
Well all I can say is so far so good...I am hoping why it took so long to download the software update that it so called took and no glitches..The mem problems drove me nuts cause sometimes the sound was set ok on Sirius then if when i started the car it went to usb stick and the sound was amped up due to radio..songs on HDD and USB were all differnt levels..The Washing DC and I agree were annoying but I could probably live with them..Said mine was partly due to when I had a dead bad battery but a new unit would prob not solve the problem..We shall see what transpires.. :thumb:
 

·
Registered
Joined
·
52 Posts
This is a very informative thread. I'm glad I came across this as I have been experiencing the same problems! Namely:

When the car is shut down:
The state defaults back to Wash DC
All saved nav locations are lost (and old ones are reverted back to existence)
Audio defaults back to Radio
The GPS takes a good 3-4 minutes to calibrate (which is a huge pain while house-hunting and trying to go from one house to another)

I plan to print out this thread and bring it in to my local dealer as proof that there is a problem, and often it is a recurring problem in an attempt to get them to replace my unit straight-away. I really don't have the freedom to spend more than an hour of my life in a dealership.

I am also wondering if the GMC Service Rep that is monitoring this thread (Michelle) has any other suggestions.

Thanks all.
 

·
Registered
Joined
·
265 Posts
let us know how you made out at your dealer...
 

·
Registered
Joined
·
303 Posts
I had the NAV software upgraded last week due to the frequent I agree screen and Washington default. Since then only once has the I Agree screen appeared and the Washington default problem has not reappeared. As nitti48 said, the software upgrade takes quite awhile (nearly 2-1/2 hours for mine).
 

·
Registered
Joined
·
75 Posts
Had mine uipgraded yesterday, the Washington DC issue has been fixed, and the other bugs, only issue is that my iphone won't been seen, but i am going to remove a bunch stuff from the iphonbe and see what happens...
 

·
Registered
Joined
·
2,772 Posts
Dutch said:
This is a very informative thread. I'm glad I came across this as I have been experiencing the same problems! Namely:

When the car is shut down:
The state defaults back to Wash DC
All saved nav locations are lost (and old ones are reverted back to existence)
Audio defaults back to Radio
The GPS takes a good 3-4 minutes to calibrate (which is a huge pain while house-hunting and trying to go from one house to another)

I plan to print out this thread and bring it in to my local dealer as proof that there is a problem, and often it is a recurring problem in an attempt to get them to replace my unit straight-away. I really don't have the freedom to spend more than an hour of my life in a dealership.

I am also wondering if the GMC Service Rep that is monitoring this thread (Michelle) has any other suggestions.

Thanks all.
Michelle was assisting me while I was out of the office. I am glad to see that you are planning to work with your local dealer regarding your concern. Please feel free to keep me posted. You can also contact me via private message. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
75 Posts
With my Iphone, I re-sync it with Itunes and it worked great... so far no problems!
 

·
Registered
Joined
·
265 Posts
Since my last post I have seen the I Agree once and the Washington DC once..Since then everything has been working fine..My memory with usb..HDD and radio has been working ok too..I mean if I turn the car off in USB then next day turn it on its scanning usb to the song I was playing..Same with XM Serius and HDD..My Ipod Touch also works great and shows up on screen...Thanks
 

·
Registered
Joined
·
6 Posts
I've had the same problem and frustration for almost a year now (I've 2010 Terrain with NAV)
- Had to agree to terms every time I want to use NAV
- NAV defaults to Washington DC
- Audio source mix up, never goes back to where I left it upon engine off & on.
- Clock off by an hour. I correct it, but it reverts upon engine off & on. This has been painful to explain to every person that sits in my car.
- I no longer able to save NAV locations nor can I delete saved ones.
- To top it all off, I cannot pump fuel hands free. I've had to stand outside holding the nozzle even on rainy days to get fuel.

I've taken the car to the dealer 3 times. So far, they only succeeded fixing the clock. I was also told by the dealer the fuel pump is working as designed, which I do not believe. For the Nav, they wanted to keep the car up to a week, which I haven't done so far...

What should I do now?

Thanks
 

·
Registered
Joined
·
978 Posts
Abel1 said:
What should I do now?

Thanks
Take it to a real dealer (meaning...another one)
 
1 - 20 of 127 Posts
Top