GMC Terrain, Equinox, and SRX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Alright, this one is in the category of minor annoyance but it's an annoyance none the less. In 2 months since I've had my 11 SRX I have gotten gas about 5 times. When I get gas I typically engage the trigger mechanism that allows the gas to pump and then shut off automatically when full. That way I can clean the windshields or whatever while the gas is pumping. I have not been able to do that with my SRX so far. I am finding that the gas opening/receptical is at such an angle that I have to lift the gun almost like I'm shooting the gas downward. Because of that angle, when I set the auto pump latch and then try to leave it alone, the weight of the hose pulls the nozzle down and the latch disengages. I get my gas at the same Speedway all the time and have tried a couple different pumps there. I will try a different station next time just to see if maybe it's the design of the Speedway pumps.

Just wondering if anyone else experiences this or I am just missing something.........
 

·
Registered
Joined
·
59 Posts
Don't know where you are located, but here on the west coast we have the nozzles with the vapor recovery system and I have the same problem. I have to hold the nozzle at a certain angle to fill the tank or it shuts off.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
Jimmy, thanks for the input. Were you previously able to use the auto latch but can't now with an SRX? Or are you saying that the vapor recovery system prevents anyone from using the auto latch? I'm in Ohio. I'm not sure what the vapor recovery system is, to be honest, but if that's simply the rubber/corregated cone that covers the opening during the gas pump then, yes, we have that too. My issue is that I was able to use the auto/latch feature with no problem in my last car (all cars prior as well) but now with my SRX because of the angle of the opening, it doesn't work.

Thanks
 

·
Registered
Joined
·
482 Posts
Sounds sorta familiar. Were I go they don't have the latch to keep fuel flowing any more but I know with the rubber thing on nozzle at some place it will shut off all the time and require you to change the angle to keep it going. You could try locking it at a slower flow rate and it might work (or not ;D)
 

·
Registered
Joined
·
468 Posts
put the nozzle in upside down. it will look funny and tricky to balance but it will work.
 

·
Registered
Joined
·
1,082 Posts
Dont stick the nozzle in so deep. Try different lengths but if you put it in too deep, itll shut it off really fast because its feeling the pressure from the filler tube splashing the gas back.
 

·
Registered
Joined
·
59 Posts
Don7019 - Yes, the vapor recovery system is the same thing it sounds like you have in Ohio. We have the latch, but if the rubber corregated thing does not seal properly it will shut off. We are in Arizona today and got fuel without the rubber thing and the nozzle worked great. Bottom line, it sounds like the angle of the filler tube does affect that type of device.
 

·
Registered
Joined
·
748 Posts
I had the same problem when I first got my vehicle. I don't know if the pump nozzles were changed or if the vehicle just got "used" to it but it let's me pump without a problem now.
 
1 - 8 of 8 Posts
Top