GMC Terrain, Equinox, and SRX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hello about 2 weeks ago i unplug my battery to fix the hose that goes to rear wiper it had come off and washer fluid was leaking from it problem solved. my next problem accuried a week later too my 07 equinox in for emission and state inspection. inspection pass emissions not ready. i was told since i unhooked my battery the obd has to read a drive cycle. was told to drive 75-100 miles then bring back in to have retested. 150 miles later took back same problem. go drive another 100 and bring it back. 100 miles later took back same problem. i got the story to keep driving some more. i own a innova diagnostic scan tool almost 700 miles later my scan tool is still showing that emissions is still not ready. no codes come up. so what is my next step what should i do.
 

·
Registered
Joined
·
715 Posts
If you are under 80,000 miles, the dealer should fix that as you have an 80K warranty on emissions.

Some years and some states, it's 150,000 miles.

You could pull the fuse for the computer or disconnect the battery again and then go for another 100 mile drive.

My 2¢
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Well come to find out if u just keep on driving it will eventually store a drive cycle. Check last not showed my emissions were ready took it today n all monitors were ready an passed. So I recorded a little over 800 miles on my vehicle.?
 
1 - 5 of 5 Posts
Top