GMC Terrain, Equinox, and SRX Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
748 Posts
Discussion Starter #1
So I was on my way to Atlanta yesterday. I was on I20 WB towards Atlanta with the cruise control on. When all of a sudden the car shot up to about 6,000 rpm and stayed there!!! We weren't on a hill or a down slope. Georgia is relatively flat near Augusta anyway. The car stayed there at a perfect 6,000 for about 5 seconds until I cut it off. Scared the &[email protected]#! out of me. After I cut it off and reset it, it has not done it sense. Anyone else ran into this?
 

·
Registered
Joined
·
1,085 Posts
Phantm006 said:
So I was on my way to Atlanta yesterday. I was on I20 WB towards Atlanta with the cruise control on. When all of a sudden the car shot up to about 6,000 rpm and stayed there!!! We weren't on a hill or a down slope. Georgia is relatively flat near Augusta anyway. The car stayed there at a perfect 6,000 for about 5 seconds until I cut it off. Scared the &[email protected]#! out of me. After I cut it off and reset it, it has not done it sense. Anyone else ran into this?
You were driving a Toyota, right?
LOL, JK!
Bad joke!
Seriously, glad no one was hurt and definitely bring it to the dealer and take them for a spin!
 

·
Registered
Joined
·
10,394 Posts
Phantm006 said:
So I was on my way to Atlanta yesterday. I was on I20 WB towards Atlanta with the cruise control on. When all of a sudden the car shot up to about 6,000 rpm and stayed there!!! We weren't on a hill or a down slope. Georgia is relatively flat near Augusta anyway. The car stayed there at a perfect 6,000 for about 5 seconds until I cut it off. Scared the &[email protected]#! out of me. After I cut it off and reset it, it has not done it sense. Anyone else ran into this?
Honest - last Saturday, with cruise on, and a level road, doing about 65 "or so", my '10 Equinox with 4 cyl. did the SAME thing. It downshifted 2 gears, and the tach shot up to 5300 rpm. My heart skipped a beat, and then I tapped the brake, to turn off the cruise, and things were fine after that. It was all over a matter of about 3 seconds. Scared the crap out of me. Anyone else have this happen ? Should this be documented with some safety organization ?

THX
 

·
Registered
Joined
·
830 Posts
I had no problem with my cruise control since i have the Terrain... I've seen that you both have the 4cyl engine... maybe a problem linked to that ? i have the v6 and no problem... call your dealer to have the system checked.
 
M

·
Guest
Joined
·
0 Posts
I have a V6 as well...which doesn't struggle as much as an I4, meaning less likely the cruise would feel like it needs to drop a couple gears and take off to keep up.

However; if you're on level terrain and it does this sounds like a major safety issue. I'd take it to the dealer.

Was there a strong headwind?...this alone might hold the vehicle back enough to feel it needs to drop a few gears. When your engine went up to 6000rpms you would have accellerated and did it stop at the setpoint speed or was it continuing to take off faster and faster?
 

·
Registered
Joined
·
748 Posts
Discussion Starter #6
That's the thing about it. No wind, no hill up or down. No nothing. Just went from about 70 where it was set and started to accelerate. No input at all from me. But the weird thing is it's like the cars systems froze. The radio cut off, the display was on but no music. The speedometer didn't move. Just the tach. Really weird. I'm just glad we didn't get hurt. Or slam into the big rig ahead of me. I wonder if GM knows about this and didn't speak on it because of Toyotagate.
 

·
Registered
Joined
·
1,537 Posts
I'd take it to the dealer immediately and have them check the code and see what's going on. That's not right.
 

·
Registered
Joined
·
10,394 Posts
I plan to report my incident to the NHTSA. You should also.
 

·
Registered
Joined
·
107 Posts
I have the I-4 in my Terrain and have not had any issues at all with it. I drove from Quebec to Alberta using it constantly and never experienced anything like you have mentioned. In fact, I could almost predict the shift patterns as I was climbing hills. So I don't think that it is related to the I-4 as compared to the 6....but anyway, definitely have it checked out by the service department.
 

·
Registered
Joined
·
239 Posts
I have no proof to back this up so I feel kinda silly for spreading what amounts to little more then internet gossip but...
I've read about this on a few other vehicle forums over the years and the one theory that keeps comming up over and over again is grossly overpowered radios in big rig trucks causing systems in nearby vehicles to go bonkers. The theory as I've seen it speculates that there are some trucks running very powerfull transmiter amplifiers(far more powerfull then the FCC allows for) on their radios and that when the drivers of those trucks 'push to talk' the signal they broadcast is powerfull enough to interfere with the electronics in nearby vehicles.
 

·
Registered
Joined
·
1,537 Posts
That's one scary thought. When I think of all the 18 wheelers I've passed on my Harley .....oh-oh. ;D
 

·
Registered
Joined
·
119 Posts
I use my cruise control almost on a daily basis (assuming traffic isn't to bad of course) I never had this issue.

ps I hit 30k miles yesterday
 

·
Registered
Joined
·
239 Posts
GARYD said:
That's one scary thought. When I think of all the 18 wheelers I've passed on my Harley .....oh-oh. ;D
Harley's are built mostly of parts desigend during the cold war era, designed to withstand an EMP, I think you'll be OK.
 

·
Registered
Joined
·
1,537 Posts
Very funny! ROTFLMAO
 
1 - 14 of 14 Posts
Top