GMC Terrain, Equinox, and SRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Newbie here. Great site. Did not know that Terrain has forum until now :eek:. Anyway I brought my 2010 Terrain 4 Cyl AWD to the dealer to fix the code (check stabilitrac... sp) and also to check on rough idling and noise when idling a few weeks ago. They changed the solenoid but did not find the other complained that my wife experienced and said that the solenoid does a lot of weird things too. Work and drive okay until 2 days ago. Now the lights came ON. Went to Advance to read it and it is PO172 (too rich). I also hearing some noise on the engine while it is on idle. My milage just reach over 36,400 miles. Is this something on the power train warranty? Is anyone having similar problem? Was the fix under warranty? I love this GMC as with my 2001 Yukon XL and this truck went to the dealer more than my Yukon that has over 105k mile (never went in for service). Car is driven by my daughter and my wife. Any info is greatly appreciated.
 

·
Registered
Joined
·
949 Posts
Sounds like you had the repair done before the 36,000, right? So, if it's the same check engine code as before, then I would think that it will be treated as a failed repair attempt, and they would attempt the repair again, but not sure. If you read around here, you'll find that the late model 2011's have many problems with the solenoids, so we know a little bit about them.

However, I personally don't know anything about that specific engine code. From what I've experienced, the codes that would pop up for bad solenoids would be P0014 and/ or P0011.
 

·
Registered
Joined
·
371 Posts
Pretty sure this would under powertrain as well as be covered because it wasn't fixed right the first time.
 

·
Registered
Joined
·
2,772 Posts
notv8 said:
Newbie here. Great site. Did not know that Terrain has forum until now :eek:. Anyway I brought my 2010 Terrain 4 Cyl AWD to the dealer to fix the code (check stabilitrac... sp) and also to check on rough idling and noise when idling a few weeks ago. They changed the solenoid but did not find the other complained that my wife experienced and said that the solenoid does a lot of weird things too. Work and drive okay until 2 days ago. Now the lights came ON. Went to Advance to read it and it is PO172 (too rich). I also hearing some noise on the engine while it is on idle. My milage just reach over 36,400 miles. Is this something on the power train warranty? Is anyone having similar problem? Was the fix under warranty? I love this GMC as with my 2001 Yukon XL and this truck went to the dealer more than my Yukon that has over 105k mile (never went in for service). Car is driven by my daughter and my wife. Any info is greatly appreciated.
I would recommend bring the vehicle back to your local dealer for more assistance. Please keep me posted and contact me with further questions. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
An update... Dealer fixed tha car under warranty. What they found are two codes... P0300 and P0172. And the repair states... Tech found two DTC's and bulletins stating to perform fuel cleaning and induction service. Tech also found an update for the ECM. Tech performed ECM update and also performed induction and fuel service. Vehicle seems to idling normally.Anyone else here know that the rough idling was fixed by ECM update?
I am still surprised that they still did not find the real cause of rough idling but hoping that the ECM update should take care of the rough idling. Hopefully that the rough idling is fix as my warranty is over.... Just need to tell my wife and daughter to let me know right away if they suspect something is up again as I don't drive the car.
 
1 - 5 of 5 Posts
Top