GMC Terrain, Equinox, and SRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2 weeks ago, the car overheated, so I added coolant. The next day, I noticed a puddle of coolant near the water pump. Took it to the shop and they suggested that is was the seal on the water pump.
I replaced the water pump with a friend on Monday. It started to over heat on the way home so I pulled over, saw that the level was low, added coolant and drove home. Figured it was air in the system.
No further issues since then until this morning when I noticed a puddle of coolant on the street underneath the water pump again. Level was very low. It has been raining since Monday so it has probably been leaking the whole time.
Thoughts?
 

·
Registered
Joined
·
2,102 Posts
It's possible you got a bad water pump when you changed out the first one.
That is a long shot though, more likely a bad gasket or installation.

Before changing it again, buy or borrow a pressure tester that attaches at the radiator cap.
If you have the 2.4L water pumps are not fun to change.
Pump it up and look for the leak to be sure where it's coming from.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
The guy that helped me is very knowledgeable and even switched out the timing chain, tensioners etc. He put Permatex all around the water pump before installation.
And yes, removing the water pump on the 2.4L was no fun at all.

I will look into a pressure tester. Thanks for the reply.
 
1 - 3 of 3 Posts
Top