GMC Terrain, Equinox, and SRX Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
Has anyone else had the fake 'chrome' around the rear GMC badge on the liftgate start to bubble? The dealership is ordering a replacement for us, hopefully this isn't going to be a repeating problem like the power steering has been.

I can throw up pictures if anyone is curious as to what it looks like.
 

·
Registered
Joined
·
1,085 Posts
Mobius said:
Has anyone else had the fake 'chrome' around the rear GMC badge on the liftgate start to bubble? The dealership is ordering a replacement for us, hopefully this isn't going to be a repeating problem like the power steering has been.

I can throw up pictures if anyone is curious as to what it looks like.
Haven't seen anything of that nature on our Terrain and hopefully never do.
I can imagine what it looks like but a picture's worth a thousand words.
;)
BTW, can you post a link to power steering issues?
Haven't had issues in that area either, just curious.
 

·
Registered
Joined
·
698 Posts
I know you had a power steering system failure. But can you elaborate on your ongoing issues?

My Terrain power steering system seems weak. Lots of noise when turning at low speeds.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #4
I've updated my thread on the power steering, check it out here:
http://www.terrainforum.net/index.php?topic=93.0

As for the chrome, I will post pictures here today. My fiancee saw another Terrain the other day that had the same problem, although their problem was much worse. You could see the bubbling from 30+ feet away.

Terrain: Have you checked the PS fluid level?

Oh, and because it seems that the only time I post on here is because of something negative, I'll add a positive bit: The looks of the Terrain have definitely grown on me, I now find it quite substantial to look at.
 

·
Registered
Joined
·
698 Posts
No I haven't checked the fluid to be honest. I will soon though.

As for any bubbling chrome, I don't see any on either the liftgate piece or the bottom bumper piece.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #6
Here are some pictures, forgive the dirt. We're in the middle of spring thaw:







The other Terrain was much worse, the entire piece was a mass of bubbles.
 

·
Registered
Joined
·
1,085 Posts
Navyaero said:
Why is your car so dirty? Just kidding but maybe it is due to where you live is it really hot there[/color]?
I'd guess it's really cold there?

Mobius said:
Here are some pictures, forgive the dirt. We're in the middle of spring thaw[/color]:

The other Terrain was much worse, the entire piece was a mass of bubbles.
P.S. thanks for updating your Power Steering issue thread, Mobius.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #9
Navyaero said:
Why is your car so dirty? Just kidding but maybe it is due to where you live is it really hot there?
Lol, I just went and washed it. We've had it quite warm for the last couple of days, and all the snow has melted. Now the roads are nothing but soupy sand/salt.
 

·
Registered
Joined
·
25 Posts
Hmm maybe it has something to do with tempature changes was it really cold out and you drived into a warm garage or something?
 

·
Registered
Joined
·
89 Posts
Discussion Starter #11
Navyaero said:
Hmm maybe it has something to do with tempature changes was it really cold out and you drived into a warm garage or something?
Well, it stays outside all of the time, the only time it sees a warm garage is when it is at the dealership. Still, that shouldn't happen regardless of where it was parked.
 

·
Registered
Joined
·
111 Posts
Had same problem on a center cap for the driver side wheel. Replaced by GM under warranty. Has to do with improper application of the faux chrome. They should warranty with no problem.
 

·
Registered
Joined
·
1,082 Posts
jimmyisland said:
sorry to say, but that's ugly. The GMC version has never impressed me with it's design, but the 'Nox did won my heart totally.
And some of us Terrain owners dont like the 'Nox either however we dont go around posting it. ;)
 

·
Registered
Joined
·
2 Posts
I had the same problem with the rear chrome and it was replaced last week....we will see if this new piece lasts. also have had other problems with faulty battery (dead Cell) only one wek old, rear bumper paint peeling, and now the plastic protective tap over the paint in fron of the rear wheels is bubbling!
 

·
Registered
Joined
·
1 Posts
I just had the same issue with the chrome on the back. I just got it replaced on Monday.... I really hope it doesn't happen again - it looked horrible!!! I was really disappointed that it happened in the first place and that it started happening only a few weeks after we bought the car.
 

·
Registered
Joined
·
1,537 Posts
At first when I saw the pics, I thought it might have been the clear protective film that was bubbling, but then the other pics showed it was the chrome. I'm keeping an eye on all the chrome from now on.
 

·
Registered
Joined
·
2,271 Posts
they replaced mine (chrome piece) about a month ago and now I notice that this new piece scratches with just about anything
I use a shammy to dry the vehicle and this new piece looks like its been on the vehicle for 5 years.....
 
1 - 19 of 19 Posts
Top