GMC Terrain, Equinox, and SRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
I just installed an updated GMC intellilink computer module today to my Terrain SLE-1 and now have Pandora and bluetooth streaming. I noticed right away how disappointing the audio quality was with constant skips and stuttering in both. I paired my wife's Galaxy S6 later tonight and it ended up helping my phone bluetooth quality. Its not as good as my wife's CX-5 pandora quality.

I am curious if there are any software updates I could get from my dealer? The version on my radio is E0.0E.14.40. Does anyone else with Intellink in their Terrain have a later software version?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #2
Does anyone else get static where it sounds like artist is singing under water with a stutter every 5 minutes while they use Pandora?
 

·
Registered
Joined
·
127 Posts
scottfern said:
Does anyone else get static where it sounds like artist is singing under water with a stutter every 5 minutes while they use Pandora?
I don't bother with Pandora, but what you are describing is what I have heard on other compressed audio sources, as in mp3's on both discs and on cheap flash drives, where the file/s have missing or corrupted bits. Sounds to me as if there might be a problem with either reception or there's an issue with buffering. I'd rule out locale first.

Pieter
 

·
Registered
Joined
·
1,373 Posts
Re:

I use Pandora about 95% of the times in my Terrain. No occasional sound problems. No static.
The only trouble I have is an occasional Bluetooth connection hangup when first starting up. (Had this problem with 4 different phones, so I'm pretty sure it's a bug in the Intellink and pretty sure GM won't fix it.)
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
So I went to the dealer today and they claimed they couldn't reproduce the issue, but said there was a bluetooth / software update available for my radio. I am dropping off the Terrain on Friday to have the software updated. I really hope this fixes this annoying issue.
 

·
Registered
Joined
·
20 Posts
What module are you speaking of? I have the SLE1 terrain without blutooth streaming.

Can't believe they would leave that out, works for phone but we want more money to stream music, also I can't believe that this version has a subwoofer built in only to use active noise reduction!

I'm very interested in looking into this before I go possibly buy a blutooth adapter. I'm also going to be buying a upgraded amp for the 8 speaker system to activate that **** sub that is about useless with the current amp in my car.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #7
crazytlingit said:
What module are you speaking of? I have the SLE1 terrain without blutooth streaming.

Can't believe they would leave that out, works for phone but we want more money to stream music, also I can't believe that this version has a subwoofer built in only to use active noise reduction!

I'm very interested in looking into this before I go possibly buy a blutooth adapter. I'm also going to be buying a upgraded amp for the 8 speaker system to activate that **** sub that is about useless with the current amp in my car.

I purchased an upgraded "brain box" that sits behind the HVAC controls and is basically the computer driving the radio components. I do have a disappointing update today. I dropped my Terrain off at the local Chevy dealer and they called me around dinner time to tell me that the box did not come with the vehicle (which I already knew) and once they determined that they were unable to continue troubleshooting. They basically said the harness and other components inside my Terrain were not fully compatible with the Intellilink module box.

It does "work" but I just get static and distortion every couple of minutes seemingly at random intervals. I really don't think I can live with that and will have to return the unit. Oh well lesson learned.
 
1 - 7 of 7 Posts
Top