GMC Terrain, Equinox, and SRX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
for me the rear heads or the ones near cabin are more prone maybe of the position and since the catalitic converter sits and makes some force on that head with all the exhaust weight. Im rebuilding them on 2007 Nox, also replacing front crank seal
 

Attachments

·
Registered
Joined
·
35 Posts
I had pushrods in but not to torque specs, i made the mistake of not confirming the torque, well broke a bolt on the pushrods in the head, Yikes, not good, got a extractor kit, use magnets, got duct tape all around the broken bolt, bought wireless drill, used a mix of ideas got to pull it out no harm done to heads. ordered new bolt from rockauto, meawile was considering to replace oil pan gasket, still thinking of doing it or not, have oil leak only at the front near front oil seal, wil replace front crankshaft seal, seems the engine has to be lifted to pull out the oil pan.
 

·
Registered
Joined
·
35 Posts
just did my head gaskets, temp gauge stays below halway all the time never moves.

The Nox is just a peacefull ride now, the total of the job was $300 with all the parts and labor
 

·
Registered
Joined
·
35 Posts
did it my self, only took me 5 months, jajajaj, had a beater to drive for the time, it died the day I got the Nox back on track again
 

·
Registered
Joined
·
35 Posts
mine is running fine, however the front timing cover is leaking, i was about to do it but thought it was the heads so now i will have to first get my 98 grand cherokee 5.2 back running and tackle the front timing cover on the 2007 equinox, the jeep is in need of the crank position sensor, new cables, new distributor cap and rotor and should be fine, these cars keep you busy some times
 

·
Registered
Joined
·
35 Posts
well its been 8000kms after the head gasket job, still running ok, now here is a question if anyone has had it, I get belt tensioner makes a sound and serpintine belt flutters some times, and sometimes it does not do it, I replaced the belt and the belt tensioner both new and still does it, could it bee that the engine is not fine tunned and kind of gets out of syncro so it kind of its not steady and make the belt flutter. Any ideas, only with AC on, if I turn the AC to off it quiets down to normal
 
1 - 6 of 6 Posts
Top