GMC Terrain, Equinox, and SRX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
Push AC button and compressor starts and Nox starts cooling in either outside air or recirc mode as long as fan is on and knob is near the blue cool area. This is normal.
Here is the strange part. Not mentioned in the manual.
With AC button not on (no amber light) push in the recirc button (fan needs to be turned) and the AC (compressor) will kick on and start cooling. The AC button does not light up and there is no notice on screen that AC is on. Also at this point if you then push in the outside air button the AC will turn off. Check it out. Is this normal or what?
Second issue could be another thread, the vibration in the steering wheel and shift knob when AC is on. Shifting into neutral when at stop gets rid of some of the vibration not all.
Anybody experiencing any of these things?
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #2 ·
I forgot that my info. is not posted on the left side like the other GM forum. I guess I should go in and list that.
In the meantime the details are; 2010 Equinox 1-LT with 4-Cyl FWD and regular AC (not auto) and just went over 1000 miles (5 weeks old tomorrow). Manufactured the last week of January 2010. If you need more info please let me know.
Thanks,
Chuck
Naples, Fl.
 

·
Registered
Joined
·
635 Posts
ccharlie said:
Push AC button and compressor starts and Nox starts cooling in either outside air or recirc mode as long as fan is on and knob is near the blue cool area. This is normal.
Here is the strange part. Not mentioned in the manual.
With AC button not on (no amber light) push in the recirc button (fan needs to be turned) and the AC (compressor) will kick on and start cooling. The AC button does not light up and there is no notice on screen that AC is on. Also at this point if you then push in the outside air button the AC will turn off. Check it out. Is this normal or what?
Second issue could be another thread, the vibration in the steering wheel and shift knob when AC is on. Shifting into neutral when at stop gets rid of some of the vibration not all.
Anybody experiencing any of these things?
Link to page about A/C compressor running...

http://www.equinoxforum.net/index.php?topic=571.msg6215#msg6215
 

·
Registered
Joined
·
20 Posts
I have the exact same NOX. When the AC comp is on there is some vibration in the wheel and geal shift. Its worse if its in ECON mode (even lower RPM by approx 200). I have a feeling that this is normal as GM keeps the RPM's low for MPG. If while in gear and just barely step on the gas you will notice it will smoth out. It may also have to do with the direct injection on this I4.
 
1 - 5 of 5 Posts
Top