GMC Terrain, Equinox, and SRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
My 2012 Terrain SLT FWD has both the ABS and stabilitrac lights on.
Took and had codes read and C0035 came up (driver side wheel speed sensor)
Replaced both front sensors. At parking lot speed when starting out I get a pulsation from brake pedal. had this same thing before replacing sensors. Is there something else I can check, if so how?
Brakes appear normal after driving at speeds above 35 MPH.
 

·
Registered
Joined
·
2,156 Posts
My 2012 Terrain SLT FWD has both the ABS and stabilitrac lights on.
Took and had codes read and C0035 came up (driver side wheel speed sensor)
Replaced both front sensors. At parking lot speed when starting out I get a pulsation from brake pedal. had this same thing before replacing sensors. Is there something else I can check, if so how?
Brakes appear normal after driving at speeds above 35 MPH.
If you just replaced the sensors you might have a bad wheelhub/bearing.
Clear all codes and drive it.
It might take several ignition cycles to clear the code out of BCM memory.

Also your problem could be wiring, connections at the sensor, or warped rotors.
 

·
Registered
Joined
·
3,522 Posts
You may have more than one problem. I had a C0045 code pop up on my 2011 Nox LT almost 10,000 miles ago (rear driver side wheel speed sensor). It set off the ABS, Stabilitrack, and Traction Control alarms on the Cluster - but no driveability issues.

I did nothing.

The alarms kept coming randomly from August last year through the end of the year - at highway speeds or just around town. Still no driveability issues. I even took a 2400 mile trip in December, driving continuously 900 miles *twice* ... and not a single alarm on the Cluster.

And now, having done absolutely nothing to “fix” this problem, I haven’t seen an alarm in months!

So - I’m not saying there’s no problem... but after resigning myself to either having to replace the sensor, the hub, or both - I’m now questioning that and thinking it’s something more nebulous.

https://www.equinoxforum.net/#/topics/28391?page=1
 
1 - 5 of 5 Posts
Top