GMC Terrain, Equinox, and SRX Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I HAVE A 2015 GMC TERRAIN, MY ABS AND STABILIZER LIGHT ARE ON.
WHEN I FIRST TURN CAR ON NO WARNING LIGHTS ARE VISIBLE BUT AFTER I DRIVE AN TRY TO BRAKE I GET
A GRINDING SOUND COMING FROM THE BRAKES THEN WARNING LIGHTS GO ON THE THE GRINDING SOUNDS STOPS. I BUT NEW BRAKES,ROTORS AND CHECKED ABS SENSORS THAT LOOK NEW. DOES ANY ONE HAS HAD THE SAME ISSUE IF SO WHAT CAN I DO
 

·
Registered
Joined
·
196 Posts
So based on your original post, when starting to move the abs and stability lights will come on. When these come on you will have codes. When you took it to your mechanic it may be possible that when he plugged in his scanner the vehicle had been shut off and then started. That may be why no codes showed up although they should have been in History. It is also possible that your mechanic may not have had a scan tool that would read the EBCM. As Lagger said above, it is probably the abs sensor but you will need a proper scan to narrow it down to what side etc.. Get that fixed and the stability warning will also go out. Good luck with it
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Ok eventhough I. He k abs sensors and they look new no dirt or grime or can it be the abs module. I was not there when my mechanic checked my brother in law went. Everything works except for the warning lights and everything looks new. Thank you both for your input
 

·
Registered
Joined
·
196 Posts
Its really good to help and I hope you get it sorted. Do not look at the condition of the sensors in of themselves, there are plenty of items that fail that look really good. People get brand new car batteries and the battery fails internally so exterior condition does not indicate performance. Now can it be the ABS module? It is possible but highly unlikely as there are other more likely items to look at first. You really need to scan the vehicle especially if those lights are on, that way you have the best shot at capturing the problem. As this is the ABS system, the codes will start with C. It will probably also give you piece of mind that its not the abs module and the expense that will incur. Let us know what you find as it will help the rest of us.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Ok I did obd2 scanning and no dtc available. Took for a 2 mile drive and nothing registered. Obd scanner was still trying to pick abs system but no codes given what should be my next step. Any suggestion
 

·
Registered
Joined
·
196 Posts
Based on what you are saying, the scanner that you are using is not meant to read those codes. It is not surprising as some scanners will only read the powertrain codes and nothing else, no B,C only the P codes. Rather than springing for a more expensive scanner, you should be able to go to Autozone or equivalent and have them read the codes for you. Ask first if their tool will read ABS codes (it should) and then you will have a better idea. Bring someone with you to stay with the car as you will need to keep it running, otherwise those lights will go out and they may not be able to read anything. If the lights are on, and they plug in and cant find anything, then you may have no choice but to go to a dealer and let them tell you the problem, you may then have a problem the ABS module itself not communicating (very rare)
Sorry i cannot help you beyond that, I do not have the information I need to be more pinpointed.
 

·
Registered
Joined
·
554 Posts
U codes need to be read also. Those are CAN communication codes. All 4 code families need to be read to get the big picture for a true diagnosis.
 

·
Registered
Joined
·
23 Posts
Not sure if similar but when I had my 2012 Terrain, I had the ABS and service stabilitrak lights on, pulsating brakes and the dealer replaced the wheel hub.

 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
ok I changed the both front sensors and light still is going on with pulsating brakes.
I did have battery disconnected to try a reset computer but computer did not reset.
I am looking for ECU fuse but can't locate it, the owners manual is not giving me wear to find it any suggestion on where
is the ECU fuse located
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Ok FYI guys i was able to have abs/stibilitrak light go off. I changed both hub bearings and the front driver side hub sensor was broken i will attach the picture. it's a shame that the hub bearing itself was still good. But i changed both for
my piece of mind and problem was fixed thank you for all your help
 

Attachments

1 - 14 of 14 Posts
Top