GMC Terrain, Equinox, and SRX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I've had my 2011 Terrain Since the end of November and something I've noticed since day 1 is how it always seems to be in too high of a gear, especially in lower speeds. At around 40mph it seems to be all the way in 6th, doing around 1500-1600 RPMs. The problem is then when I want to speed up and press the gas, it's very slow to respond and slightly vibrates the car because it's geared too high and I need to press the gas enough to get it to downshift into a lower gear. I have a road that's hilly that I commute on daily and it's especially bad there, when it's all the way in 5th or 6th and I'm trying to go up a hill and have to step on it to get it to downshift. Lately I've began putting it into manual mode in 5th and it doesn't seem to go above 5 gears that way, but I shouldn't have to do this just to have a smooth drive.

Is this the way the 4cyl is supposed to be? I'm pulling crappy MPG (18-19) so it obviously isn't helping if that's the intention. I understand the 4cyl has a good deal less power than the 6 but I don't read too many others on here talking about this issue.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
Terra-Nox said:
Are you driving with ECO on?
I've driven with both and it does the same in both modes, ECO and regular. At first I thought it was ECO that was causing it to shift so quickly but found it to do the same with it off.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #8 ·
What I've been doing for a week or so now is putting it into M5 and driving with it on, letting it automatically shift up and down but never going above 5th gear. This way it stays out of 6th and it handles the hilly drive to work better. But this is annoying.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top