GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I started to have an issue with my 2019 Premier Diesel yesterday morning. I am currently at 2915 miles and filled DEF about 10 days ago. Garage kept.
When I start the engine from cold (not driven in at least 5 hours), there is a loud ticking then the engine starts stuttering? Not a mechanic so I don't know how else to describe it. Almost a rough idle. The tach goes up slightly. It will do this about 1-3 mins in park then stop. It will restart this once I put in reverse and then drive. It goes away after running/ driving (roughly 6-8 mins after running). So far, it has done this on 3 occasions. I drive 20 mins to/ from work, mostly traffic 35 mph. Weekends I take for a longer drives of 30- 45 mins at 60 mph.

I called the dealership and have an appointment this afternoon. Just wanted to see if anyone has any insight on what this may be before I take it in and have the dealership throw mechanic speak at me.
 

·
Registered
Joined
·
3,505 Posts
Maybe try PM'ing "tizan", "HC041", and "Larrywal"?

I think all three have the diesel engine.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Just an update, in case anyone has the same issue in the future. Dealership has had my vehicle for 1 week now, case opened with GM. Problem is intermittent and has not been resolved. It is referred to as an "engine bauble". No idea what that means. Basically sounds like the engine stutters to me.
 

·
Registered
Joined
·
665 Posts
Sorry that you are having issues. Obviously not normal. We have not have this issue...18000 miles now.
People have been having some sensor malfunctions and this causes the ECM to do the wrong thing...here could be not pumping enough air (spooling the turbo faster) in or diesel to cause it to stutter...

Somebody had an injector replaced if i remember on this forum...but all these should throw a CEL i suspect...




If they do not fix it fast don't forget to look into getting a new one through lemon law buy back or similar.


Good luck and let us know how it goes
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
Thanks, y'all. Almost 10 days in the shop, I finally got back today. Still no answers. Waiting on GM to review the data and provide a solution. Issue is still intermittent and happened while in the dealer care.

This is the second time in the shop since buying. First time was due to tail light module holding water and having to be replaced. Told the service guy I need a frequent punch card.
 

·
Registered
Joined
·
665 Posts
Please do let us know if/when they come up with a solution.

As this is a newish engine in North America (introduced in 2016 in the cruze though longer in Europe) there is not much info about problem/solution.


If it is an injector being partially blocked it will get better or worse i suspect with time.
If it is a sensor which starts functioning well with higher temperature...i suspect it will reappear more frequently in the colder months.


when you get your oil changed ...tell them to purge the fuel filter of water as it is recommended in the manual...though if it is water in the fuel you would have had a DIC message about it according to the manual.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
Going back in to shop this week. The last time it was there for this issue (engine bauble), GM closed the case without a solution. Summer months it was mostly fine but it has started up again now that it is getting cooler. I have also started to experience random engine shuttering? Like transmission slipping when the vehicle is between 40- 60 mph; RMPs between 1200- 1600; flat and inclined roads. Completely random and no idea how to reproduce it.

Oh, and this morning I received a "Service Rear Vision System" blue screen on my Infotainment. I am still below 7,000 miles and just had my first oil change last week.

My confidence in GM products is waning. I love the car but I feel I have had my fair share of issues.
 

·
Registered
Joined
·
9,973 Posts
I just read that the terrain will still offer the diesel in 20. Not sure how reliable it was car and driver.
 

·
Registered
Joined
·
665 Posts
Oh, and this morning I received a "Service Rear Vision System" blue screen on my Infotainment. I am still below 7,000 miles and just had my first oil change last week.

My confidence in GM products is waning. I love the car but I feel I have had my fair share of issues.

I understand your frustration with the quality of workmanship...anyways the last time i saw somebody reporting on servicing rear sensors or vision system, it was due to bad wire connections. Hopefully they'll just replace the wire set and you'd be out of there.
 

·
Registered
Joined
·
51 Posts
I just read that the terrain will still offer the diesel in 20. Not sure how reliable it was car and driver.
Where? If you’re referring to the May 2019 C&D article, things have changed. Everything I have seen since summertime states it has been completely dropped, and it’s not listed on the GMC web site.

Tom
 

·
Registered
Joined
·
9,973 Posts
Tom, it was in the October car and driver. It said the diesel would only be available on the fwd terrain.
 

·
Registered
Joined
·
62 Posts
I've had some issues but not that. I had a battery go...a def filter sensor go and just recently a cel for an ecm update. Other than that all good 22k miles in 10 mos.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #17
Update- 1 week later still in shop. The Service Manager stated that the shuttering was "normal". Requested they look again because there is no way that is normal.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #18
I've had some issues but not that. I had a battery go...a def filter sensor go and just recently a cel for an ecm update. Other than that all good 22k miles in 10 mos.
Did you receive any error codes when the Def sensor failed? Any other codes?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #19
Update- over a week in the shop, could not re-produce issue. It is a random thing, does not happen daily otherwise would be easy to locate.

When I picked up the car and closed the service ticket, there was additional service repair paperwork that was never included previously. There are notes that I refused a tire rotation at the time of oil change. I did not and when I asked, I was told that they did a 27 point inspection which includes tire rotation. I asked why it was on this paperwork and the Service tech said that it wasn't on the ticket he was looking at.

Additionally, the same paperwork states that the Fuel Injector Pump was replaced in April during the previous time in the shop. My paperwork does not mention this, at all. Again, asked about it and was told that it is not on the ticket that was seeing and he didn't know where I got it from.

Now my Equinox seems to be running like it has a high idle. Not sure if that is what it is. It seems to rev up higher and then shift gears. There are times that I can press on the accelerator and the RPMs jump. I checked the "My Chevrolet" app driving activity and now it shows that I have had a few "Hard Accelerations". Is it possible the service shop adjusted any settings to make my transmission shift differently? If I brought my vehicle in to another service shop, would they be able to tell if it is not in the original factory settings?

Fortunately my husband was able to witness the vibration with the shifting previous to taking to the shop, but he does not drive my car enough to know it is driving differently.
 

·
Registered
Joined
·
190 Posts
Juli, This is all wrong! I was mentioned above as a possible source for an explanation. I wish I could. While I had my 2018 LT Diesel, (15k miles), it performed perfectly and mileage was great. I no longer have it, but I loved the vehicle and only traded it, (on Canyon Diesel), in an effort to downsize. (Also sold seldom driven 2500HD). We still have a Premier, (1.5 gas), that my wife loves.
I think you're getting a runaround and would suggest you take it to another dealer, if possible, or start a case with GM and/or the BBB.
Howard
 
1 - 20 of 24 Posts
Top