GMC Terrain, Equinox, and SRX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Have been having issues with my 2017 2.4l fwd equinox. Recently had nearly all of the front suspension parts replaced (control arm, sway bar links, struts, etc). When applying the break, an audible clunk from both the drivers and pax side can be heard. I put the car on jacks, and everything seems tight, and nothing loose. All bushings etc look fine, and everything has been greased. Has anyone else had a similar issue, and or could they possibly point in the right direction before I throw any more parts at this thing?
 

·
Registered
2011 Equinox LT 2LT 3.0 V6 AWD
Joined
·
55 Posts
You mention all the suspension parts replaced, what about the brakes themselves? Rotors, calipers, pads, caliper brackets? Could be as simple as a loose caliper bracket, or it could be a bad brake hose.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
The pads and rotors were replaced, but my friend states that the problem didn't start to happen until they put new tires on the vehicle. Looking at all the components, everything seems snug. I guess I can try putting the car back up and loosening / retorquing everyhing to spec.
 

·
Registered
Joined
·
5,272 Posts
See my posts here in regards to clunk when braking

 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
See my posts here in regards to clunk when braking

Thanks for the info. When the car gets home i'll have a good look at it! Ill report my findings when I can.
 
1 - 5 of 5 Posts
Top