GMC Terrain, Equinox, and SRX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

I own a 2015 Terrain that had the infotainment system screen go black. Have tried fuses, etc. After a trip to the dealer I'm told that the onstar module has gone bad and until it's replaced the radio/gps/bluetooth/backup camera will not work. Will removing the onstar module solve the problem? I don't use onstar so it's not like I would be missing anything. Seems crazy that this would shut everything down. I have found some places that will sell a new onstar module for less that what the dealer wants and an independent guy with a programmer but hate to spend the money if it's an easier fix. I've also considered the aftermarket route. Any advice would be appreciated.
 

·
Registered
Joined
·
6 Posts
Is your radio dead also? Our screen and radio just died. Have tried fuses and disconnecting battery. Have not made a trip to dealer. Research seems to indicate the most common cause is the radio. My On star still appears to work although we do not pay for the service.

I am trying decide if it is even worth a trip to dealer or should I purchase an aftermarket radio and skip a trip to the dealer?
 

·
Registered
Joined
·
1 Posts
gannon33 - did you get the issue resolved? I've had my 2015 Terrain at the dealership twice. After researching the part number they say will fix the problem, it doesn't fit my vehicle! So frustrated! The only thing that works is the heat/ac. Screen is blank, no radio or back-up camera function.
 

·
Registered
Joined
·
6 Posts
Update: So after not having a radio for over 6 months, I really dont want to pay $700 for a radio, my wife hit a bump on way to work and the whole system started working again.......
 

·
Registered
Joined
·
958 Posts
Update: So after not having a radio for over 6 months, I really dont want to pay $700 for a radio, my wife hit a bump on way to work and the whole system started working again.......
Sounds like an internal board connection is loose or broken and made contact again--or external power supply connection was loose.

In my old '56 BelAir with tube type radio, the vibrator/oscillator tube would frequently stop functioning; I quick smack to the dash immediately below the radio and it would start working again.
 

·
Registered
Joined
·
53 Posts
Only issue I have random on my 2014 Terrain is the backup cam goes black, if i hit area near camera on back tailgate it comes back on, so I need to take trim off and probably just clean connections, or replace cam. Wish they would make radio replacement easier, aftermarket radios look stupid since you can't install in same area as the radio screen in these Terrains and have to install in lower area and still keep oem screen in. Wish a aftermarket would make a android radio specific for terrains and equinox.
 
1 - 8 of 8 Posts
Top