GMC Terrain, Equinox, and SRX Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I am about to lose my mind. 2015 GMC Terrain about 70,200 miles. No lights appearing on dash.
This past Wednesday went to grab a few things, stopped, continued on and when came out with groceries battery was dead and had to be jumped. I let it run almost 30 minutes as I figured out where to take to have battery tested.... Autozone checked it and said battery fine. I researched what other issue could be and found alternator, but was hopeful somehow a light or something was left on. Move ahead 3 days... Car sat because I work from home and we had a large snowstorm. Got it all cleaned off and needed to get some items. Car wouldn’t start again. Proceeded to get a jumpstart pack and charge it while I used my husband’s vehicle. Came home jumped car and proceeded to Autozone. Asked them to run a full check (battery, alternator, starter, whatever possible). They couldn’t do it because battery was too low. Jumped again and sat with car running for 25 minutes. They completed tests, started it for last series and everything good. I came home looked up and found issue with Bluetooth and radio per many many places. I checked and Bluetooth had nothing connected (let me say that about 2 weeks ago the Bluetooth acted up, when receiving call didn’t automatically go to Bluetooth had to press on my phone for it to go to vehicle). I removed Bluetooth vehicle connection on phone. I had to grab item for cookies I ran out of. Car started, went 2min down road, got items went to car and battery dead within 15 min. Jumped, came home. Tried it in morning on Sunday, worked, had radio off. Tried later in day, dead, one jumped radio was on w/out me turning on. I pulled the fuses for radio & backup camera Sunday late day. Monday morning started, no issue. Now Tuesday, thinking I have fixed the problem go to start car this morning, battery dead... jump. Go to start this evening, dead.
I tried calling GMC, I chatted and got take in for testing. Mind you everything I had read says it won’t show issue. I called mechanic said never heard of this happened/nor seen but willing to test. Called GMC dealer, they said will hook up, $140/hr plus diagnostics. I don’t have thousands of dollars to fix this nor the money to get out of it into something else. I’ve had the car 2 years 3 months... What the hell is going on? The car has been treated well, great shape, new tires, new selinoid last year... was shutting off. But that’s normal. I don’t understand how nothing has happened and all sudden battery dying. Help, please!
 
1 - 1 of 1 Posts
Top