GMC Terrain, Equinox, and SRX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
We have a 2014 terrain (91,000 miles) and we're smelling exhaust fumes inside the cabin (especially while idling, like waiting in a drive-thru). The car is not super 'loud', but it has gotten a little louder over the last few months. Seems to quiet down just a tad after start-up. I have seen several mention it could be the manifold. The service engine light is NOT on. Just wondering if it might be something else or if it definitely sounds like a bad manifold.
 

·
Registered
Joined
·
969 Posts
Been there on an ‘04 Saturn Vue...no engine light either, but exhaust fumes in the car. It was a cracked manifold. Junkyard replacement for like $40 and a few hours of my time and replaced it. Massive visible crack once I got it out!
...one of the few issues that car ever had! I sold it at 280K miles right after I got my Nox...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Been there on an ‘04 Saturn Vue...no engine light either, but exhaust fumes in the car. It was a cracked manifold. Junkyard replacement for like $40 and a few hours of my time and replaced it. Massive visible crack once I got it out!
...one of the few issues that car ever had! I sold it at 280K miles right after I got my Nox...
Even with only 91k miles? I've read it's a common issue.... haven't had it looked at yet but a buddy of mine who is also a mechanic says he's fixed several of them. Was hoping maybe it's just a bad gasket but I probably couldn't get that lucky lol
 

·
Registered
Joined
·
969 Posts
Even with only 91k miles? I've read it's a common issue.... haven't had it looked at yet but a buddy of mine who is also a mechanic says he's fixed several of them. Was hoping maybe it's just a bad gasket but I probably couldn't get that lucky lol
Unfortunately, yes. My personal opinion is it’s gotta be from water splashing up from underneath in the rain. The drastic temp change has got to have something to do with it IMO...it wasn’t very well shielded in my Vue and it was a cast piece...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Unfortunately, yes. My personal opinion is it’s gotta be from water splashing up from underneath in the rain. The drastic temp change has got to have something to do with it IMO...it wasn’t very well shielded in my Vue and it was a cast piece...
Okay... thanks for your input, I really appreciate it! I'll have to get it checked out and will post an update.
 

·
Registered
Joined
·
28 Posts
I had that too. Tried switching air flow from outside to recirculate. Didn't smell it then. Must be coming out of motor I guess. Let me know what u find out please
 

·
Registered
Joined
·
10,334 Posts
Maybe a cracked exhaust manifold.
 

·
Registered
Joined
·
28 Posts
I'm thinking. Hasn't been back though either. Had what seemed to be antifreeze smell couple of times too. I love this car. Whenever I convince one of my mechanic buddies to come by she runs like a charm. Lol
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
I had that too. Tried switching air flow from outside to recirculate. Didn't smell it then. Must be coming out of motor I guess. Let me know what u find out please
Well, we bought a new manifold and O2 sensor from rockauto and are now just waiting for our mechanic to put them on.... should be next weekend (hopefully). Fingers crossed... I'll let you know if that fixed the problem!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
I'm thinking. Hasn't been back though either. Had what seemed to be antifreeze smell couple of times too. I love this car. Whenever I convince one of my mechanic buddies to come by she runs like a charm. Lol
Yep, lol, seems like that's the way it always goes....
 
1 - 10 of 10 Posts
Top