GMC Terrain, Equinox, and SRX Forum banner

2014 GMC Terrain SLT power driver's seat issues...

331 Views 7 Replies 3 Participants Last post by  Colt Hero
Hello everyone!

I am having issues with the power driver's seat on my 2014 GMC Terrain SLT. The other day it stopped working, but just the part that moves the seat forward-and-back. The up-down adjustment still works, as does the reclining seatback and the lumbar. Even the seat memory positions 1 and 2 still try to work, but of course it can't completely due to the forward-and-back not working. I think it is the motor and after so many years of moving back and forth every time the car is locked/unlocked, it is just worn out. If I move the button that makes the seat go back-and-forth, all I get is a 'click' noise. Just wanted to see if anyone with the same or near model year has had any issues with theirs. I checked the tracks on both sides and didn't see any obstructions. Right at the front of the right-hand track, I found a piece of something and I'm not sure if it is something from the seat, or if it is just part of something else that just happened to fall into the track. It was lying at the very front edge of the track, and the seat is stuck pretty far back, so I am thinking this is not what caused the issue but just wanted to mention it and post some pics of the piece I found in case anyone else that has had seat issues might have found something similar in their tracks (see pics below).

Thanks for any advice/help that anyone can provide.

Bumper Automotive lighting Gas Vehicle door Automotive exterior
Fixture Gas Automotive exterior Auto part Electric blue
Water Arthropod Insect Fluid Pest
See less See more
1 - 4 of 8 Posts

At least these parts aren't expensive (I assume this is the one you might need).

As for that broken part ... it's interesting that it appears to have ball bearings embedded in it ... like it would be used to roll back and forth in the track ... so maybe that is your real problem?

Then again ... it doesn't look very substantial ... like it could take the beating it would need to take day in and day out.

I think you're gonna have to just remove the Seat to see what really happened underneath ... and maybe bench-test the motor to make sure it's not just binding up somehow ...
Thanks for your reply! Yep, that is the correct part... I just ordered it yesterday. As you mentioned, I was thinking that I was just going to have to take the seat out and look around and just see if anything appears out of sorts, test the motor, etc. I took the chance and went ahead and ordered the motor because I'm assuming that must be it, but guess I will find out for sure soon...
Well ... like I said ... not an "expensive" part ... and worst case ... you have a spare Motor.

Here's something you might want to try ... because it works with Starter Motors (and Door Window Motors): lightly tap around the body of the Motor and give it another try. I once had a Window Motor out of the car's Door to give it a quick bench-test. It failed. But then it accidentally fell to the floor. Whadaya know ... now it passed the bench-test!

I re-installed it in the Door ... and it worked for another year (at which point I finally replaced it). I guess something got "hung up" inside the Motor (brushes?), and jarring it with the fall "fixed" the problem.
Thanks again for your replies! I was looking at it the other night again, banging on things and checking wires, connections, etc. The next day I get in, and it works... 🤷‍♂️. So, as you said, at least I have the motor if it ever goes out (maybe it's on its way now) but if I never need it, I can eventually sell it on ebay because that motor fits many GM vehicles.

Also, your profile pic... back in '89 when I started dating my (now) wife, she had a Colt and I was telling her about your profile pic. Hers was just like yours, except that it had a light blue along the bottom of the car so it wasn't all silver. Your pic brought back memories for us...
On my 2013 Nox I had a similar issue where it would not recline, but the other 7 functions worked. I took the seat out, removed the switch and sprayed a ton of electrical contact cleaner in it and worked the switdh in all directions and repeated a few times. Put it back together and it worked perfectly for several years until I traded it in.

It may not be the problem for this issue, but could help others maybe.
Thanks for your reply! I was looking at it the other night again, banging on things and checking wires, connections, etc. The next day I get in, and it works... 🤷‍♂️. If I have more issues, I will be pulling the seat out and may very well do what you mentioned before replacing the motor. I have seen electronic cleaner work miracles over the years, so it never hurts to try that.
1 - 4 of 8 Posts