GMC Terrain, Equinox, and SRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Remotely started my terrain this a.m. and it stopped after 1 min. I then started it via ignition and it started to shake and check engine light came on and service Stabilitrak came on? Took it to dealer as I also had a strange whining type noise when I slowly turned steering wheel? Any ideas?
 

·
Registered
Joined
·
3,503 Posts
Is this V6 or I-4? I believe *any* presence of CEL takes out Remote Start.

Maybe you have the I-4 and your electric steering threw a code?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
V6 and just told by dealer that my power steering pump is gone (warranty)
Engine misfiring and need ignition coil and 6 spark plugs ( me $400 and warranty $880)
Cooling line? $ me 605 and 5 days in shop to get part. Isn’t that covered by power train?
Holy Crap ..... at 75oookms????
 

·
Registered
Joined
·
3,503 Posts
V6 and just told by dealer that my power steering pump is gone (warranty)
Engine misfiring and need ignition coil and 6 spark plugs ( me $400 and warranty $880)
Cooling line? $ me 605 and 5 days in shop to get part. Isn’t that covered by power train?
Holy Crap ..... at 75oookms????
Wow! Sounds like they've had a slow week (or month) of repairs.

I've got a 2011 V6 and it's always made the groaning noise with the steering at low RPMs. I've just ignored it, but others have had a hose replaced (?) under warranty? Maybe that's all you really need, but the dealer is going to charge GM for a new pump AND hose anyway? Too bad you didn't get a chance to mark all the pieces. Probably won't even replace the pump.

Engine misfiring? You had the CEL ON (and flashing) with P0301-P0306 (misfire on cylinder #1-#6), or did they detect that as an underlying problem? Is that something that made sense to you? Could you feel the engine hesitating or missing at times? As far as those charges ... from Rock Auto, (6) A/C Delco Professional Iridium spark plugs are $32, and an A/C Delco Coil is $40, and there's a $3/plug rebate right now, so that brings the plugs down to $14! Throw in a $100 labor charge and the whole thing should stay under $200. Those are some *insane* charges that I would definitely *not* agree to.

And what cooling line? All this sounds *very questionable* to me.

Did you walk in there with a T-Shirt that said, "IT'S ONLY MONEY"? Oh wait - you got towed in, right? That automatically marks everything up *at least* 1000%

Seriously, though - at only 46,600 *miles*, these are questionable repairs with very questionable charges. I'd say it's highly likely this is fraud.
 

·
Registered
Joined
·
187 Posts
Is this V6 or I-4? I believe *any* presence of CEL takes out Remote Start.

Maybe you have the I-4 and your electric steering threw a code?
Yes, any CEL and a multitude of other things will cause the remote start to not work. Failed hood latch sensor being a common one on older cars.
 

·
Registered
Joined
·
246 Posts
Must be some gold pressed latinum pieces they are adding to your vehicle. I would understand a fee for diagnosing, but $1200 to basically have a tune-up done is crazy.

I would press them to show you what cooling line they are talking about. Is it an engine coolant line? Transmission cooling line? And how bad the leak might be.

A lot of times, you will certainly deal with these monkeys trying to upsell services for the sake of making extra money whether you need the work done or not. I could never do that job. I have a huge problem with leaving my integrity at the door.
 
1 - 6 of 6 Posts
Top